[USRP-users] Rx/Tx Loopback

Marcus D. Leech mleech at ripnet.com
Wed Apr 1 23:04:09 EDT 2015


On 04/01/2015 11:00 PM, Rob Kossler wrote:
> I don't recall any error message with the low sample rate. But, I was 
> also using higher rates like 1 MS/s and 10 MS/s also.
> Rob
>
May just be a buffering elasticity issue.

Try putting something like a multiply-const block between them, with a 
constant of 1.0.  Just to put some buffering in place.

These streams are going to the same physical device, yes?  And it has a 
1PPS input?


> On Wed, Apr 1, 2015 at 10:58 PM, Marcus D. Leech via USRP-users 
> <usrp-users at lists.ettus.com <mailto:usrp-users at lists.ettus.com>> wrote:
>
>     On 04/01/2015 05:57 PM, Rob Kossler via USRP-users wrote:
>>     I would like to run a simple Rx to Tx loopback using gnuradio
>>     companion with my X310. The attached flowgraph contains two
>>     blocks, a UHD source and UHD sink, which are directly connected
>>     to each other on each of the 2 channels.
>>
>>     When I run it, I get numerous "L" indications. To me, this
>>     indicates that I'm not delivering the samples to the Tx Streamer
>>     when it wants them.  Perhaps the start times for RX streaming and
>>     TX streaming need to be specified?  If so, can this be done from GRC?
>>
>>     Thanks.
>>     Rob
>>
>>
>>     _______________________________________________
>>     USRP-users mailing list
>>     USRP-users at lists.ettus.com  <mailto:USRP-users at lists.ettus.com>
>>     http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
>     The only thing I notice is that you've specified a really-low
>     sample rate, one which I'm thinking the X310 cannot support, did
>     you get any error messages
>       to that effect when it's running.
>
>
>     _______________________________________________
>     USRP-users mailing list
>     USRP-users at lists.ettus.com <mailto:USRP-users at lists.ettus.com>
>     http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
>
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20150401/9e089b5d/attachment-0002.html>


More information about the USRP-users mailing list