[USRP-users] XADC Usage on X300??

Robert Palumbo palumr at gmail.com
Fri Sep 26 12:32:36 EDT 2014


Ah, thanks for the information.

What's interesting is that I'm able to build and implement with an XADC
module instantiated without Xilinx firing off any warnings to me. One would
think that Xilinx would warn you about that :-)

On Fri, Sep 26, 2014 at 12:05 PM, Ian Buckley <ianb at ionconcepts.com> wrote:

> Rob
> XADC is actually already used in the SDRAM controller….because it's uber
> fast DDR3 it's used to measure temperature and dynamically adjust signal
> timing.
> Recursively search for mig_7series_v1_8_tempmon.v under
> usrp3/top/X300/coregen
>
> -Ian
>
>
> On Sep 26, 2014, at 8:39 AM, Robert Palumbo via USRP-users <
> usrp-users at lists.ettus.com> wrote:
>
> Hey,
>
> I'm trying to instantiate an XADC on my X300, to expose the build-in
> temperature/voltage monitoring capabilities. However, I can't seem to get
> any valid output from the module. I've never used an XADC before, but the
> documentation says that on-chip voltage/temperature sensors should be
> available, provided the XADC Vcc/Vaux are connected.
>
> Has anyone out there successfully instantiated and used the XADC on the
> X3xx-devices?
>
> Thanks for any help anyone can give,
>
> Rob
>
> --
> Robert A Palumbo
> palumr at gmail.com
>  _______________________________________________
> USRP-users mailing list
> USRP-users at lists.ettus.com
> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
>
>
>


-- 
Robert A Palumbo
palumr at gmail.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20140926/c53d8c0a/attachment-0002.html>


More information about the USRP-users mailing list