[USRP-users] X3x0 PCIe ExpressCard benchmark_rate transmit test rate limit

Stan Vitebsky svite at lgsinnovations.com
Mon Sep 22 10:56:12 EDT 2014


Hi Michael,

Thank you very much for your reply.
Just in case, I reinstalled the niusrprio driver again, but I am still 
getting the same result (1.4682Msps limit with 99 underruns for 25Msps/ 
10 sec benchmark_rate test)

my info is
$ modinfo nikal
filename: 
/lib/modules/3.10.33-rt32.45.el6rt.x86_64/kernel/natinst/nikal/nikal.ko
description:    National Instruments Kernel Abstraction Layer
author:         National Instruments Corporation
license:        Copyright (c) 2002-2014 National Instruments 
Corporation.  All Rights Reserved.  Any and all use of the copyrighted 
materials is subject to the then current terms and conditions of the 
applicable license agreement, which can be found at 
<http://www.ni.com/linux/>.
srcversion:     4084E53CA60B8FA4BEC7FDE
depends:
vermagic:     3.10.33-rt32.45.el6rt.x86_64 SMP preempt mod_unload

I guess, I will try to reproduce your configuration and see what happens.
-Stan


On 9/19/14, 10:09 PM, Michael West wrote:
> Hi Stan,
>
> I just tested on my system and was able to achieve 25 Msps on transmit 
> for 60 seconds with no issues (benchmark_rate --tx_rate=25e6 
> --duration=60).  Here is my configuration:
>
> System:  Lenovo T430s laptop
> Express Card:  NI Express Card-8360
> OS:  Ubuntu 13.04 (kernel 3.11.6)
> UHD:  3.7.2
> NI-USRP-RIO Driver:
>
> $ modinfo nikal
> filename: 
> /lib/modules/3.11.6-low-latency-1k-ticks/kernel/natinst/nikal/nikal.ko
> description:    National Instruments Kernel Abstraction Layer
> author:         National Instruments Corporation
> license:        Copyright (c) 2002-2014 National Instruments 
> Corporation.  All Rights Reserved.  Any and all use of the copyrighted 
> materials is subject to the then current terms and conditions of the 
> applicable license agreement, which can be found at 
> <http://www.ni.com/linux/>.
> srcversion:     21BCF3919A528389FB9E52A
> depends:
>
> Which version of niusrprio driver are you using?
>
> Regards,
> Michael
>
>
>
> On Fri, Sep 19, 2014 at 1:59 PM, Stan Vitebsky via USRP-users 
> <usrp-users at lists.ettus.com <mailto:usrp-users at lists.ettus.com>> wrote:
>
>     Hello,
>
>     Could somebody in the community please point me to the host
>     configuration (laptop, OS, uhd, system settings) that worked for
>     them with x3x0 and ExpressCard at tx rates above 1.4Msps (e.g.
>     using benchmark_rate)?
>     Has this been proven to work by anybody? If yes, I'd appreciate
>     your guidance.
>
>     Thanks,
>     -Stan
>
>>     and ExpressCard
>
>
>     _______________________________________________
>     USRP-users mailing list
>     USRP-users at lists.ettus.com <mailto:USRP-users at lists.ettus.com>
>     http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
>
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20140922/6beda79e/attachment-0002.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 3305 bytes
Desc: S/MIME Cryptographic Signature
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20140922/6beda79e/attachment.p7s>


More information about the USRP-users mailing list