[USRP-users] B210 USB transfer error

mleech at ripnet.com mleech at ripnet.com
Fri Sep 19 13:45:46 EDT 2014


 

I'd like to understand if this is sample-rate dependent. Does it happen
more frequently at higher samples rates, or is it just dependent on 

 runtime? What about when on USB-2.0? 

A goodly chunk of the R&D team at Ettus are on the road until Monday. 

On 2014-09-19 13:29, Garver, Paul W via USRP-users wrote: 

> I can also report I have had this exact same issue with a B200, although I typically run rx_samples_to_file. I've also tried external power to no avail. I've also run the B200 on the haswell Intel NUC which also has the series 8/C210 USB 3.0 controller. I haven't seen this issue yet on the NUC but I don't have a lot of runtime on it yet.
> 
> Could you please post your results to the mailing list or can Ettus support contact me offline? I'm very interested in the resolution to this issue.
> 
> System Info:
> Gigabyte Brix GB-BXi7-4770R
> Ubuntu 14.04 64 bit
> Intel Corporation 8 Series/C220 Series Chipset Family USB xHCI (rev 05)
> 
> PWG
> 
> Date: Fri, 19 Sep 2014 02:08:04 +0000
> From: "Nowlan, Sean" <Sean.Nowlan at gtri.gatech.edu>
> To: "USRP-users at lists.ettus.com" <USRP-users at lists.ettus.com>
> Subject: [USRP-users] B210 USB transfer error
> Message-ID:
> <625d92335cfe4d91923faf730b3e2a97 at apatlisdmail01.core.gtri.org>
> Content-Type: text/plain; charset="us-ascii"
> 
> Hi all -
> 
> I've seen this pop up now and again on this list. Basically while running an RX operation (osmocom_fft or uhd_fft) the B210 will sporadically disconnect from the USB 3.0 hub and then it will immediately reconnect. I can see this in dmesg and /var/log/syslog. It was suggested to me that this may be a power brown out issue since I have a TCXO GPSDO module mounted on board, but I observe the same error even while connected to wall power through the standard 6V, 3A power supply. Here is the console output I see.
> 
> UHD Error:
> The receive packet handler caught an exception.
> RuntimeError: usb rx6 transfer status: 5
> UHD source block got error code 0xf
> terminate called after throwing an instance of 'uhd::runtime_error'
> what(): RuntimeError: usb tx4 submit failed: LIBUSB_ERROR_NO_DEVICE
> Aborted (core dumped)
> 
> System info:
> Intel(R) Core(TM) i5-3210M CPU @ 2.50GHz
> USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
> Ubuntu 14.04 LTS
> linux; GNU C++ version 4.8.2; Boost_105400; UHD_003.007.002-94-ge56809a0?
> 
> Sean
> 
> _______________________________________________
> USRP-users mailing list
> USRP-users at lists.ettus.com
> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com [1]
 

Links:
------
[1] http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20140919/8c199af3/attachment-0002.html>


More information about the USRP-users mailing list