[USRP-users] B210 USB transfer error

Michael Dickens michael.dickens at ettus.com
Fri Sep 19 08:05:39 EDT 2014


Hi Sean - There was a report on GitHub < https://github.com/EttusResearch/uhd/issues/10 > about this issue, and I have 2 open support issues on it -- but, nobody is responding to help us work through what's going on.  I'll contact you off-list with a few queries & hopefully we can start working through this issue. - MLD

On Sep 18, 2014, at 10:08 PM, "Nowlan, Sean via USRP-users" <usrp-users at lists.ettus.com> wrote:

> I've seen this pop up now and again on this list. Basically while running an RX operation (osmocom_fft or uhd_fft) the B210 will sporadically disconnect from the USB 3.0 hub and then it will immediately reconnect. I can see this in dmesg and /var/log/syslog. It was suggested to me that this may be a power brown out issue since I have a TCXO GPSDO module mounted on board, but I observe the same error even while connected to wall power through the standard 6V, 3A power supply. Here is the console output I see.
> 
> UHD Error:
>     The receive packet handler caught an exception.
>     RuntimeError: usb rx6 transfer status: 5
> UHD source block got error code 0xf
> terminate called after throwing an instance of 'uhd::runtime_error'
>   what():  RuntimeError: usb tx4 submit failed: LIBUSB_ERROR_NO_DEVICE
> Aborted (core dumped)
> 
> System info:
> Intel(R) Core(TM) i5-3210M CPU @ 2.50GHz
> USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
> Ubuntu 14.04 LTS
> linux; GNU C++ version 4.8.2; Boost_105400; UHD_003.007.002-94-ge56809a0​




More information about the USRP-users mailing list