[USRP-users] X300 PCIe Driver Issues

Marcus D. Leech mleech at ripnet.com
Tue Sep 9 13:18:52 EDT 2014


On 09/09/2014 12:41 PM, Peter Witkowski via USRP-users wrote:
> Hello,
> I recently contacted Ettus support regarding this issue, but I was 
> wondering if perhaps the e-mail list could help me out sooner or even 
> confirm the issues that I am having.
>
> I currently have an X300 that is having some issues being connected 
> over PCIe.
>
> First, I have an issue where the driver seems to hang in instances 
> where an overflow is encountered.  That is, if I run uhd_rx_cfile (or 
> any other application for that matter that is receiving data) and an 
> overflow is encountered, the application hangs and stops writing to 
> disk.  No “O” characters are printed.  However, once an overflow is 
> properly caught and handled (i.e., “O” characters are printed) I have 
> no more issues with the driver hanging for the rest of that power 
> cycle.  From that point forward all overflows are properly handled.  
>   If I cycle power on the device or my host machine, the problem comes 
> back.  I tried to repeat this issue over Ethernet, and overflow errors 
> are always properly printed and handled.
>
> Second, the PCIe driver requires an Ethernet connection.  That is, if 
> I unplug a network connection, I cannot run uhd_find_devices.  I can 
> ping the loopback address just fine and have verified that the 
> loopback interface is active, but I cannot run uhd_find_devices if my 
> Ethernet connection is disconnected.
>
> I am running everything on a fresh install of Ubuntu 14.04 and have 
> verified that I have the latest FPGA image installed on the device.
>
> Please let me know what I should try to alleviate the issues that I am 
> having.  Thank you in advance for your help.
>
>
> -- 
> Peter Witkowski
> pwitkowski at gmail.com <mailto:pwitkowski at gmail.com>
>
>
> _______________________________________________
> USRP-users mailing list
> USRP-users at lists.ettus.com
> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
I can't answer about the hanging isuee, but if you:

uhd_usrp_probe -args "resource=RIO0"

That should always work if things are setup correctly.

I'm not sure what "uhd_find_devices" doesn't include the RIO resources 
in its "list of things to try", but to be honest, I vastly prefer *explicit*
   device naming, rather than implicit "find me a usrp".   If one has 
more than one USRP on a system, then implicit naming is nearly never
   what you want anyway....


-- 
Marcus Leech
Principal Investigator
Shirleys Bay Radio Astronomy Consortium
http://www.sbrac.org

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20140909/c341dab9/attachment-0002.html>


More information about the USRP-users mailing list