[USRP-users] USRP B200 Stopped working as it has in the past

Michael West michael.west at ettus.com
Mon Sep 8 19:53:34 EDT 2014


Hi Ryan,

I suggest running the UHD benchmark_rate example with some simple arguments
to test access to the device and basic TX and RX streaming.  Something like
"benchmark_rate --rx_rate=1e6 --tx_rate=1e6" should do the trick.  Assuming
that works, try creating a simple GRC flowgraph that does the same thing.
If that all works, delete and recreate the UHD USRP Source/Sink block(s) in
your flowgraph and see if it fixes the issue.

Best regards,
Michael

On Sat, Sep 6, 2014 at 6:55 PM, Ryan Bosley via USRP-users <
usrp-users at lists.ettus.com> wrote:

> I've been playing with the USRP B200 for several months now and have
> generally had decent luck getting things working.  But, today for some
> reason, things stopped working.  It appears to load the FPGA image
> correctly and starts to run, but before the flowgraph can run  I get
> errors (see below).
>
> Note these are the same flowgraphs that worked fine just this morning.
> Any insight into what might be happening is appreciated.
>
> -Ryan
>
>
> Generating: "/home/ryan/My_gnuradio_flowgraphs/uhd_wbfm_receive.py"
>
> Generating: "/home/ryan/My_gnuradio_flowgraphs/uhd_wbfm_receive.py"
>
> Executing: "/home/ryan/My_gnuradio_flowgraphs/uhd_wbfm_receive.py"
>
> linux; GNU C++ version 4.6.3; Boost_104800; UHD_003.007.001-84-gd99ce4ef
>
> Using Volk machine: sse4_2_64_orc
> -- Loading firmware image: /usr/local/share/uhd/images/usrp_b200_fw.hex...
> done
> -- Loading FPGA image: /usr/local/share/uhd/images/usrp_b200_fpga.bin...
> done
> -- Operating over USB 2.
> Traceback (most recent call last):
>   File "/home/ryan/My_gnuradio_flowgraphs/uhd_wbfm_receive.py", line
> 294, in <module>
>     tb = uhd_wbfm_receive(samp_rate=options.samp_rate,
> address=options.address, freq=options.freq, gain=options.gain,
> audio_output=options.audio_output)
>   File "/home/ryan/My_gnuradio_flowgraphs/uhd_wbfm_receive.py", line
> 168, in __init__
>     channels=range(1),
>   File "/usr/local/lib/python2.7/dist-packages/gnuradio/uhd/__init__.py",
> line 122, in constructor_interceptor
>     return old_constructor(*args)
>   File "/usr/local/lib/python2.7/dist-packages/gnuradio/uhd/uhd_swig.py",
> line 1761, in make
>     return _uhd_swig.usrp_source_make(*args)
> RuntimeError: AssertionError: accum_timeout < _timeout
>   in uint64_t radio_ctrl_core_3000_impl::wait_for_ack(bool)
>   at
> /home/ryan/gnuradio/uhd/host/lib/usrp/cores/radio_ctrl_core_3000.cpp:228
>
> _______________________________________________
> USRP-users mailing list
> USRP-users at lists.ettus.com
> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20140908/481faf1a/attachment-0002.html>


More information about the USRP-users mailing list