[USRP-users] X310, 2 channel sample time and phase alignment

Ian Buckley ianb at ionconcepts.com
Tue Sep 2 13:37:25 EDT 2014


Thats a giant delay…nothing I can think of internal to X310 could account for that. I don't suppose you accidentally used a 180 degree splitter instead of a 0 degree? I only ask because I ddi the same once and wasted a bunch of time…

On Sep 2, 2014, at 10:28 AM, Marcus D. Leech via USRP-users <usrp-users at lists.ettus.com> wrote:

> On 09/02/2014 01:25 PM, Kemp, Elizabeth - 1008 - MITLL wrote:
>> Thank you for the reply Marcus!
>>  
>> I just plotted as a complex pair and it still doesn’t have the proper phase alignment...  I’m using UHD version 3.7.1.
>>  
> Could you update to 3.7.2?
> 
> Also, how are you setting up the two channels?  Are they on two different BASIC_RX?
> 
> 
>> -Liz
>>  
>>  
>> From: USRP-users [mailto:usrp-users-bounces at lists.ettus.com] On Behalf Of Marcus D. Leech via USRP-users
>> Sent: Tuesday, September 02, 2014 11:49 AM
>> To: usrp-users at lists.ettus.com
>> Subject: Re: [USRP-users] X310, 2 channel sample time and phase alignment
>>  
>> On 09/02/2014 11:23 AM, Kemp, Elizabeth - 1008 - MITLL via USRP-users wrote:
>> Hi,
>>  
>> I have a test set up where I am recording on both channels of an X310.  I have the output of a signal generator connected to the channels through a splitter (and equal length cables).  I am using the BasicRX Daughterboards (1-250 MHz).
>>  
>> I have attached a screenshot from GRC of the WX GUI that shows a plot of the real samples, and the magnitude of the two channels.  As you can see in the magnitude plot, the two channels seem to be time-aligned, but there is a huge phase offset between the two channels.  I’ve observed that the phase offset varies across different frequencies.
>>  
>> So my question is – why is there a phase offset between the 2 channels?  Is there anything that can be done to correct it?
>>  
>> Thanks for your help,
>> Liz
>> 
>> 
>> 
>> _______________________________________________
>> USRP-users mailing list
>> USRP-users at lists.ettus.com
>> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
>> There may not be.  In the past, the scope sink has had issues with proper phase display.  If you plot it as a complex pair instead, it maintains proper phase
>>   display.
>> 
>> Also, what version of UHD are you using?
>> 
>> 
> 
> _______________________________________________
> USRP-users mailing list
> USRP-users at lists.ettus.com
> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20140902/21d26003/attachment-0002.html>


More information about the USRP-users mailing list