[USRP-users] X310, 2 channel sample time and phase alignment

Marcus D. Leech mleech at ripnet.com
Tue Sep 2 13:28:36 EDT 2014


On 09/02/2014 01:25 PM, Kemp, Elizabeth - 1008 - MITLL wrote:
>
> Thank you for the reply Marcus!
>
> I just plotted as a complex pair and it still doesn't have the proper 
> phase alignment...  I'm using UHD version 3.7.1.
>
Could you update to 3.7.2?

Also, how are you setting up the two channels?  Are they on two 
different BASIC_RX?


> -Liz
>
> *From:*USRP-users [mailto:usrp-users-bounces at lists.ettus.com] *On 
> Behalf Of *Marcus D. Leech via USRP-users
> *Sent:* Tuesday, September 02, 2014 11:49 AM
> *To:* usrp-users at lists.ettus.com
> *Subject:* Re: [USRP-users] X310, 2 channel sample time and phase 
> alignment
>
> On 09/02/2014 11:23 AM, Kemp, Elizabeth - 1008 - MITLL via USRP-users 
> wrote:
>
>     Hi,
>
>     I have a test set up where I am recording on both channels of an
>     X310.  I have the output of a signal generator connected to the
>     channels through a splitter (and equal length cables).  I am using
>     the BasicRX Daughterboards (1-250 MHz).
>
>     I have attached a screenshot from GRC of the WX GUI that shows a
>     plot of the real samples, and the magnitude of the two channels. 
>     As you can see in the magnitude plot, the two channels seem to be
>     time-aligned, but there is a huge phase offset between the two
>     channels.  I've observed that the phase offset varies across
>     different frequencies.
>
>     So my question is -- why is there a phase offset between the 2
>     channels?  Is there anything that can be done to correct it?
>
>     Thanks for your help,
>
>     Liz
>
>
>
>
>     _______________________________________________
>
>     USRP-users mailing list
>
>     USRP-users at lists.ettus.com  <mailto:USRP-users at lists.ettus.com>
>
>     http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
>
> There may not be.  In the past, the scope sink has had issues with 
> proper phase display.  If you plot it as a complex pair instead, it 
> maintains proper phase
>   display.
>
> Also, what version of UHD are you using?
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20140902/9da4ce8f/attachment-0002.html>


More information about the USRP-users mailing list