[USRP-users] X310 MTU frame size issue

Michael West michael.west at ettus.com
Fri Oct 24 14:08:36 EDT 2014


Hi Louis,

Are you stopping GRC by closing the pop-up window or by the "Kill the
flowgraph" button in the toolbar?  I ask because they operate differently.
Closing the pop-up window will exit the application cleanly and you should
be able to run over and over again.  Using the "Kill the flowgraph" button
in the toolbar is equivalent to using Ctrl-C and can leave the device in an
undesirable state.  As you have observed, the device eventually returns to
a usable state even if you kill the application but it could take a few
seconds.

Regards,
Michael

On Fri, Oct 24, 2014 at 9:16 AM, Louis Brown <rfengr00 at me.com> wrote:

>
> Regarding my previous post, I have found if I wait until the X310 link light goes from red to off, about 10 seconds, I can re-establish communication.  If I try to run my GRC flow when the link light is red, it finds the incorrect MTU.  So I guess the rule is, always wait until the link light is off until you re-run your flow graph.
>
> Lou
>
> On Oct 23, 2014, at 08:40 PM, Michael West <michael.west at ettus.com> wrote:
>
> Hi Louis,
>
> I noticed that for the benchmark_rate you are supplying the IP address and
> for GRC you are not.  Try supplying the same args ("addr=192.168.40.2") in
> the "Device Addr" field of the UHD USRP Source/Sink block you are using.
>
> Regards,
> Michael E. West
>
> On Thu, Oct 23, 2014 at 6:31 PM, Louis Brown via USRP-users <
> usrp-users at lists.ettus.com> wrote:
>
>> Operating my X310 from a UHD source in GRC via 10GE yields a low MTU at
>> startup:
>>
>> -----------------------------------------------
>> linux; GNU C++ version 4.8.3 20140911 (Red Hat 4.8.3-7); Boost_105400;
>> UHD_003.008.000-6-gbde8e9a3
>> -- X300 initialization sequence...
>> -- Determining maximum frame size... 2188 bytes.
>> UHD Warning:
>>
>> Sent from iCloud
>>
>>     For this connection, UHD recommends a send frame size of at least
>> 8000 for best
>>     performance, but your system's MTU will only allow 2188.
>>     This will negatively impact your maximum achievable sample rate.
>> -----------------------------------------------
>>
>> My MTU for the 10GE interface is 9000 (verified with ifconfig), and when
>> I run benchmark_rate it finds the correct MTU:
>>
>> ------------------------------------------------
>> ./benchmark_rate --rx_rate 200E6 --args "addr=192.168.40.2"
>> linux; GNU C++ version 4.8.3 20140911 (Red Hat 4.8.3-7); Boost_105400;
>> UHD_003.008.000-6-gbde8e9a3
>>
>> Creating the usrp device with: addr=192.168.40.2...
>> -- X300 initialization sequence...
>> -- Determining maximum frame size... 8000 bytes.
>> -----------------------------------------------
>>
>> So is this a GR issue or a UHD issue, or a combination?
>>
>> Thanks,
>> Lou
>> KD4HSO
>>
>>
>> _______________________________________________
>> USRP-users mailing list
>> USRP-users at lists.ettus.com
>> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
>>
>>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20141024/04575c16/attachment-0002.html>


More information about the USRP-users mailing list