[USRP-users] USRP-users Digest, Vol 50, Issue 20

Ralph A. Schmid, dk5ras ralph at schmid.xxx
Wed Oct 22 01:45:00 EDT 2014


Very interesting – but for me it does not work, going from 250kHz in some steps up 8M made the thing freeze like when directly starting with 32M.

 

Ralph.

 

 

From: USRP-users [mailto:usrp-users-bounces at lists.ettus.com] On Behalf Of Terry Stevenson via USRP-users
Sent: Tuesday, October 21, 2014 6:35 PM
To: usrp-users at lists.ettus.com
Subject: Re: [USRP-users] USRP-users Digest, Vol 50, Issue 20

 

Hi Soumen,

 

This sounds like a problem that I was having a while ago (assuming you're on Ubuntu, otherwise I have no idea). It appears to be an issue in the UHD driver, hopefully it is fixed in a future update. My workaround is a bit weird, but I was able to make it stop crashing by first lowering the sample rate, then raising it back up. For example, uhd_fft defaults to 1Msps, if I leave it there, it runs a while and then crashes. If I lower it to 500 ksps it runs awhile and still crashes. However, if I lower it to 250 ksps, then raise it back to 500 ksps, it will run for weeks and still not crash. It's very strange, but it's consistent. For reference, I'm using 3.7.2.

 

Hope this helps,

Terry

 

 


Greetings!

I managed to install gnuradio and uhd and it seems to be able to detect the usrp device. It shows up in the output of lsusb.

I was trying out the simple fm radio demonstration and that one kept crashing. No debug output, nothing. It just froze. So I thought Ill look at the basics and tried to run the uhd_fft app (from path). I put the sampling frequency in the FM band since I know the FM stations over here and I was able to see peaks at the expected frequencies, but its not a continuous FFT. It just freezes immediately after the first graph is plotted. Is there something that Im missing? Im inclined to think that the installation went all right because the peaks in the snapshot FFT match so well with the expected radio stations!

I noted that someone else has had this problem with a N210 before, and they solved it by updating the OS and playing around with the Ethernet settings, but Im connected to the B210 over USB, so that method can't be tried.

Any suggestions?

Thanks!
Soumen

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20141022/53b07040/attachment-0002.html>


More information about the USRP-users mailing list