[USRP-users] Boost Requirements (Was: 3.8.0 build issues on centos 6)

Ben ROBERT robert.benoit at gmail.com
Tue Oct 21 10:18:32 EDT 2014


Martin Braun via USRP-users <usrp-users at ...> writes:

> 
> On 10/15/2014 12:21 AM, Stan Vitebsky via USRP-users wrote:
> > I have trouble building newly released uhd 3.8.0 on Centos 6 (3.10.33
> > kernel).
> > [...]
> > I suppose this is because this file doesn't exist in boost 1.41, which
> > is default for Centos 6.
> > Does this mean that Centos 6 will no longer be supported by uhd?
> 
> Everyone,
> 
> we will indeed be bumping our minimum Boost version to 1.46 for 3.8.0.
> As you've already discussed in this thread, this doesn't mean we CentOS
> 6 won't work anymore, as it's a simple matter to update Boost.
> If you're using PyBombs to install UHD, this will automate the process
> for you.
> 
> A short note on distros: We will make an effort to make UHD build on any
> not-too-old Linux (and other OSes) that meet our dependencies, but we
> mainly test on current Ubuntu and Fedora versions (those for which we
> also provide binary installers), Mac OS X and Windows 7. If it doesn't
> matter to you which distro you're using, we thus recommend Ubuntu or
> Fedora, but as I said, we'll do our best to write portable code to make
> it work on most platforms.
> 
> Cheers,
> Martin
> 

Hi everybody,

I am trying to build UHD 3.8.0 on Ubuntu LTS 12.04 and I am facing the same
problem with file shared_lock_guard.hpp missing.
I have libboost-all-dev 1.48.0.2 installed. May be a higher version of boost
library is required.

Cheers,
Benoit









More information about the USRP-users mailing list