[USRP-users] UHD Apps freeze with USRPB210

Ralph A. Schmid, dk5ras ralph at schmid.xxx
Tue Oct 21 02:10:23 EDT 2014


This sounds similar to my actual experiences. With the last release the USB
disconnect problems are gone, but especially at higher sampling rates the
system freezes after seconds up to one minute. Command line programs then
show errors like this one:

 

UHD Error:

    The receive packet handler caught an exception.

    ValueError: bad vrt header or invalid packet length

UHD source block got error code 0xf

 

At the moment I have no idea what is happening, the whole thing is far from
being usable at the moment, while it operates under Windows on the same PC
for hours, so at least the hardware is OK.

 

OS is Kubuntu 14.04 32 bit low latency. 

 

Unfortunately I was not able to build uhd on my Kubuntu 12 system, compile
stops with some nirio error, but I do not have the time at the moment to go
deeper into this. 

 

Ralph.

 

 

From: USRP-users [mailto:usrp-users-bounces at lists.ettus.com] On Behalf Of
Banerjee, Soumen via USRP-users
Sent: Monday, October 20, 2014 6:08 AM
To: usrp-users at lists.ettus.com
Subject: [USRP-users] UHD Apps freeze with USRPB210

 

Greetings!

 

I managed to install gnuradio and uhd and it seems to be able to detect the
usrp device. It shows up in the output of lsusb.

 

I was trying out the simple fm radio demonstration and that one kept
crashing. No debug output, nothing. It just froze. So I thought Ill look at
the basics and tried to run the uhd_fft app (from path). I put the sampling
frequency in the FM band since I know the FM stations over here and I was
able to see peaks at the expected frequencies, but its not a continuous FFT.
It just freezes immediately after the first graph is plotted. Is there
something that Im missing? Im inclined to think that the installation went
all right because the peaks in the snapshot FFT match so well with the
expected radio stations!

 

I noted that someone else has had this problem with a N210 before, and they
solved it by updating the OS and playing around with the Ethernet settings,
but Im connected to the B210 over USB, so that method can't be tried.

 

Any suggestions?

 

Thanks!

Soumen

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20141021/ec525929/attachment-0002.html>


More information about the USRP-users mailing list