[USRP-users] N210 Stops Transmitting

Liwei xieliwei+usrp at gmail.com
Sun Oct 19 14:17:18 EDT 2014


Hi all,
    My mind is officially blown now. Everything suddenly works.
    After returning the MacBook to my friend, I started collecting the
data Marcus asked for. The first thing I did was to load new firmware
with usrp_n2xx_simple_net_burner (since the UHD version on my laptop
is newer than the one from macports on the MBP). Next I tried to run
the tx_waveforms test as suggested. I was expecting the same result
since tx_waveforms should behave similar to uhd_siggen. To my
surprise, it actually worked without issue.
    So I went back to uhd_siggen thinking maybe the problem lies with
gnuradio. Again, I was surprised when it actually worked fine. Then I
tried the test flow graph, then the flow graph I was working on, on
fast ethernet, on the USB3 gigabit ethernet adapter, and even Wi-Fi.
Now I have uhd_siggen running at 2.5Msps over Wi-Fi for the past 15
minutes without issue.

    3 weeks recompiling different UHD/GNURadio versions, power
cycling, firmware updating, swapping network devices around, network
capturing, and things suddenly start working without clear
explanation.

    So there are a few things that could have solved the problem:
        1. Switching to the older firmware/UHD/gnuradio version from the MBP
        2. Switching back to the new firmware/UHD/gnuradio version
from my laptop
        3. Running tx_waveforms (does it do anything especially
different from uhd_siggen?)
        4. Sentience, I did hint in my previous email of replacing
this USRP unit with the spare ;)

    To be sure, I just power cycled the N210 and rebooted my laptop.
Still works. Hopefully this holds up and what I've provided so far is
of use in figuring out what exactly was happening.

Thanks
Liwei

On 20 October 2014 00:55, Liwei <xieliwei+usrp at gmail.com> wrote:
> Whoops, attached the generated python instead of the flow graph. See attached.
>
> On 20 October 2014 00:50, Liwei <xieliwei+usrp at gmail.com> wrote:
>> Hello Marcus, Marcus,
>>     Thanks for the reply. I'll get back to what the two of you have
>> asked me to check in the next email. At the moment, I managed to get
>> myself a mid-2010 MacBook Pro (running OS 10.10) from a friend. It
>> runs on a 2.66GHz i7-620M (Arrandale) processor with a BCM5701 gigabit
>> ethernet controller.
>>
> --Snip--




More information about the USRP-users mailing list