[USRP-users] 3.8.0 build issues on centos 6

Marcus Müller marcus.mueller at ettus.com
Wed Oct 15 17:00:52 EDT 2014


Short notes from my side, especially to document this for the people who
might search the mailing list later on:On 15.10.2014 22:44, Stan
Vitebsky via USRP-users wrote:
> Yes, this is still using gcc 4.4.7, so I am getting a bunch of #pragma
> related warnings that I assume is safe to ignore - I believe they
> should go away with later versions of gcc.
Yes, the "#pragma diagnostic push/pop" related warnings go away with gcc
4.6.5, as far as i can tell. They are safe to ignore from what I've seen.
> I did not have to do anything special except building from source and
> installing boost 1.55 and making the adjustment in Responder.cpp.
Responder.cpp is fixed in the current master since a few hours :)
> I did upgrade the kernel from 2.6.32 to 3.10.33 with RT_PREEMPT patch.
> This was not related to any uhd 3.8.0 build issues though.
> It was something I did some time ago, so I cannot say if there are any
> additional issues you might encounter when working with the stock kernel.
>
> I will update you if I notice anything else when I start running uhd
> 3.8.0
Thank you!

Greetings,
Marcus





More information about the USRP-users mailing list