[USRP-users] 3.8.0 build issues on centos 6

Stan Vitebsky svite at lgsinnovations.com
Wed Oct 15 16:44:14 EDT 2014


Hello Neel,

Yes, this is still using gcc 4.4.7, so I am getting a bunch of #pragma 
related warnings that I assume is safe to ignore - I believe they should 
go away with later versions of gcc.

I did not have to do anything special except building from source and 
installing boost 1.55 and making the adjustment in Responder.cpp.

I did upgrade the kernel from 2.6.32 to 3.10.33 with RT_PREEMPT patch. 
This was not related to any uhd 3.8.0 build issues though.
It was something I did some time ago, so I cannot say if there are any 
additional issues you might encounter when working with the stock kernel.

I will update you if I notice anything else when I start running uhd 3.8.0

Best Regards,
-Stan


On 10/15/14, 3:42 PM, Neel Pandeya wrote:
> Hello Stan:
>
> Thanks for your feedback. It's very useful information. Other than 
> upgrading Boost to version 1.55, was there anything else that you had 
> to do in order to get UHD 3.8.0 to build on CentOS 6? You're using the 
> default GCC 4.4.7?
>
> I noticed that you had upgraded the kernel. You said you're running 
> 3.10, and the default for CentOS 6 is 2.6.32. Although this shouldn't 
> affect building 3.8.0, it might be important when running 3.8.0.
>
> --Neel
>
>
> On Wed, Oct 15, 2014 at 12:08 PM, Stan Vitebsky via USRP-users 
> <usrp-users at lists.ettus.com <mailto:usrp-users at lists.ettus.com>> wrote:
>
>     Hi Ben,
>
>     Thank you for your reply.
>     Just FYI, after building and installing boost 1.55 on Centos 6,
>     now uhd 3.8.0 builds ok
>     (the only issue that I still had to fix was to remove "d" from
>     line 504 of /utils/latency/lib/Responder.cpp)
>
>     -Stan
>
>
>
>     On 10/14/14, 7:45 PM, Ben Hilburn wrote:
>>     Hi Stan -
>>
>>     Thanks for letting us know! We'll look into it. It does sound
>>     like we may need to bump the minimum required version of Boost.
>>
>>     Cheers,
>>     Ben
>>
>>     On Tue, Oct 14, 2014 at 3:21 PM, Stan Vitebsky via USRP-users
>>     <usrp-users at lists.ettus.com <mailto:usrp-users at lists.ettus.com>>
>>     wrote:
>>
>>         Hello,
>>
>>         I have trouble building newly released uhd 3.8.0 on Centos 6
>>         (3.10.33 kernel).
>>         Previous release as well as the current maint branch are
>>         building successfully.
>>         The first error that fails the build is that
>>         boost/thread/shared_lock_guard.hpp file cannot be found in
>>         include/uhd/transport/nirio/niriok_proxy.h on line 26.
>>         I suppose this is because this file doesn't exist in boost
>>         1.41, which is default for Centos 6.
>>         Does this mean that Centos 6 will no longer be supported by uhd?
>>
>>         Thanks,
>>         -Stan
>>
>>
>>
>>
>>
>>
>>
>>
>>         _______________________________________________
>>         USRP-users mailing list
>>         USRP-users at lists.ettus.com <mailto:USRP-users at lists.ettus.com>
>>         http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
>>
>>
>
>
>     _______________________________________________
>     USRP-users mailing list
>     USRP-users at lists.ettus.com <mailto:USRP-users at lists.ettus.com>
>     http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
>
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20141015/7f75ee6d/attachment-0002.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 3305 bytes
Desc: S/MIME Cryptographic Signature
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20141015/7f75ee6d/attachment.p7s>


More information about the USRP-users mailing list