[USRP-users] Receiving problem with USRP N210

Marcus Müller marcus.mueller at ettus.com
Wed Oct 15 12:47:08 EDT 2014


Hello Su Li,

just a few general RF engineering debugging approaches:

* check your measurement set up. Is it the right antenna for this
frequency range, attached to the right port (believe me, I mistakenly
used the wrong port quite a couple of times), at the right receiving
bandwidth/sampling rate, with a feasible gain? If you don't risk
damaging your device, crank up the gain!
* A scope sink can impossibly show you fast bursty signals; if you know
your spectral shape (eg. it's GMSK with a 3dB bandwidth of 200kHz, or
it's 10MHz wide OFDM or so), use the waterfall sink. It will give you
some more long-time visual impression. Generally, any frequency domain
sink will most probably be better suited than using the scope sink.
* If that signal is spread-spectrum, you might not notice anything at
all looking at the spectrum or time domain signal at all. I don't know
this specific system, and I must admit it's a bit much asking for help
without giving us a few edge parameters to guess from ;)
* If you happen to know the pulse shape, implement a matched filter. You
seem to have a software sender -- so you should have the possibility to
get to know that shape. If the pulse shaping is in fact done by a FIR,
you could just take the taps and use their time-reversed conjugate as
the matched filter. That should give you some processing gain :)

Greetings,
Marcus

On 15.10.2014 17:02, Su Li via USRP-users wrote:
> Hi,
>
> I have an USRP N210 with RFX2400 2.3-2.9GHZ RX/TX. I am trying to build a
> communication link between Tmote sky wireless sensor node and USRP N210.
>
> I use Tmote sky node to repeatedly broadcast messages on radio channel 26
> with power level 31 (=0dBm). The code I use is the example code of Contiki
> and I can receive this broadcast message by a receiver implemented by a
> Tmote sky node.
>
> However, I cannot receive the message on USRP N210. When I tried to check
> the signal that the antenna received, I found nothing except the noise. In
> GNU radio companion, I just used a UHD-USRP Source with frequency at
> 2.48GHz to get the signal from USRP and check them in a  Scope sink. I
> thought the power of the received signal would increase a lot when the
> sensor node broadcast messages. But I did not see a large increment of the
> amplitude of the signal. I also tried using trigger to catch the burst
> spike, but I failed.
>
> Anyone can give me some suggestions to fix this problem?
>
> Thanks in advance.
>
> Best regards,
> Su
>
>
>
> _______________________________________________
> USRP-users mailing list
> USRP-users at lists.ettus.com
> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20141015/cfb2c691/attachment-0002.html>


More information about the USRP-users mailing list