[USRP-users] USRP x310 RF A TX Red LED

Ryan Marlow rynmrlw at vt.edu
Mon Oct 13 13:43:13 EDT 2014


Hey Martin, All,
I was worried that the LED mix up was an indication of something horribly
wrong with my USRP. I messed around with some other daughter boards and
configurations and I think I had just misconfigured some things because I
can now get data coming through. Thanks for the info.
Ryan



> Date: Mon, 13 Oct 2014 17:38:01 +0200
> From: Martin Braun <martin.braun at ettus.com>
> To: usrp-users at lists.ettus.com
> Subject: Re: [USRP-users] USRP x310 RF A TX Red LED
> Message-ID: <543BF1D9.6080804 at ettus.com>
> Content-Type: text/plain; charset=ISO-8859-1
>
> A green LED means receive, and a red LED means transmit. In the early
> versions of the X300 code, this was accidentally flipped, which was not
> a problem per se, but inconsistent with our other devices.
> So no, a red TX LED is not bad, no worries!
>
> As for the bug you see with 'only receiving noise', that's strange and
> probably not connected to the LED colour. There's a chance some gain
> settings changed across versions, although I haven't heard that before.
> Maybe you can elaborate on your test setup.
>
> M
>
> On 10/10/2014 11:04 PM, Ryan Marlow via USRP-users wrote:
> > Hey All,
> > I'm playing around with different versions of the released UHD. I have a
> > simple flowgraph in GNU Radio with a USRP source and sink. and the TX
> > and RX are looped together. I'm trying to just get dataflow through the
> > USRP. UHD 3.7.1 seems to work great. The signal I send to the USRP
> > matches what the USRP sends back to GNU Radio, great! But in UHD 3.7.2
> > and 3.7.3 the TX LED is red instead of green and I appear to just be
> > getting noise back to the host. What exactly does the RED LED indicate
> > (I'm sure it's bad)? In all cases, I run the uhd_usrp_probe utility tool
> > and no significant errors result from that. I'm not sure what I'm doing
> > wrong.
> > Thanks,
> > Ryan Marlow
> >
> > --
> > Ryan L. Marlow
> > Research Assistant in CCM Lab <http://ccm.ece.vt.edu>
> > Virginia <http://www.vt.edu/> Polytechnic Institute and State University
> >
> >
> > ______________________________
> _________________
> > USRP-users mailing list
> > USRP-users at lists.ettus.com
> > http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
> >
>
>
>
> --
> Ryan L. Marlow
> Research Assistant in CCM Lab <http://ccm.ece.vt.edu>
> Virginia <http://www.vt.edu/> Polytechnic Institute and State University
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20141013/ccd83727/attachment-0002.html>


More information about the USRP-users mailing list