[USRP-users] N210 Stops Transmitting

Liwei xieliwei+usrp at gmail.com
Wed Oct 8 13:10:13 EDT 2014


Hello list,
    This may have been asked before (I vaguely remember seeing an
email with a similar issue some time back), but what causes UHD to
stop sending transmission packets to an N210?
    With a simple flowgraph [signal source] -> [uhd sink] at 200k
sample rate over gigabit ethernet, I get up to about 3 seconds of
transmission before everything suddenly goes silent.
    Here's what I see logged:

linux; GNU C++ version 4.8.2; Boost_105400; UHD_003.007.002-107-g0ca4b4f8

-- Opening a USRP2/N-Series device...
-- Current recv frame size: 1472 bytes
-- Current send frame size: 1472 bytes
SU

    Nothing else after "SU".

    Interestingly, if I add a receive + fft chain in the same
flowgraph, the receive stream works fine even after the transmission
has stopped. In fact, if I loop the TX and RX ports on the N210
together (with an attenuator in between) I can see, in the received
signal fft, the frequency peak for the few seconds the N210 is able to
transmit.

    Gqrx also works well receiving FM radio stations all the way up to
about 10MHz sampling rate, after which samples start to get dropped.

    I'm running on a fresh install of Ubuntu 14.04, with everything
installed using pyBOMBS. I've tried switching to yesterday's 3.7.3
maint branch but no difference. Firmware and FPGA image were updated
after each version switch.

    Attached is a screenshot in Wireshark showing the sudden
transmission stop. Note that only packets originating from the
computer is shown.

    Also attached is the output from uhd_usrp_probe.

    $ uname -a
Linux Ubuntu 3.15.0-031500rc2-generic #201404201435 SMP Sun Apr 20
18:36:18 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

    It may be due to a buggy ethernet adapter, but I've achieved over
900MBits/s for both TX and RX over iperf. I've also tried another Fast
(instead of gigabit) ethernet adapter and even Wi-Fi, but no
difference. There is currently a Dell managed switch in-between the
computer and N210, but I've tried directly connecting both together
with no difference in results either.

    Also, the current setup works flawlessly with a B210 which I have on hand.

    At this point, any hint would be great!

Thanks
Liwei
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Screenshot from 2014-10-09 00:47:43.png
Type: image/png
Size: 244083 bytes
Desc: not available
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20141009/b8541426/attachment.png>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: probe_details
Type: application/octet-stream
Size: 2989 bytes
Desc: not available
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20141009/b8541426/attachment.obj>


More information about the USRP-users mailing list