[USRP-users] B210 UHD FPGA

Martin Braun martin.braun at ettus.com
Mon Oct 6 05:04:35 EDT 2014


Konstantin,

which UHD version are you using? Also, am I understanding you correctly
that you built your FPGA images yourself? If so, do ours work?

Cheers,
M

On 10/03/2014 03:22 PM, Konstantin via USRP-users wrote:
> Dear Sirs,
> I'm dealing with Ettus B210 board and I have the following problem.
> I built the B210 FPGA source code and it worked well a few month ago.
> Thereafter I update local copy of repository and I can see there are few
> changes in repository during some months.
> Now I can build FPGA source code for B210 board but when I try to start
> FPGA bin image I have the next error
> 
> 
>> sudo ./rx_ascii_art_dft --freq 24000000 --gain 30 --rate 4000000
> 
> Creating the usrp device with: ...
> -- Loading firmware image:
> /usr/local/share/uhd/images/usrp_b200_fw.hex... done
> -- Loading FPGA image: /usr/local/share/uhd/images/usrp_b210_fpga.bin...
> done
> -- Operating over USB 2.
> Error: AssertionError: accum_timeout < _timeout
>   in uint64_t radio_ctrl_core_3000_impl::wait_for_ack(bool)
>   at /home/cubie/uhd/host/lib/usrp/cores/radio_ctrl_core_3000.cpp:232
> 
> I try to start it on Linux and Windows but I have the same error.
> 
> Could you check this error on B210 or B200 board ?
> 





More information about the USRP-users mailing list