[USRP-users] rx_samples_to_file issue

gsmandvoip gsmandvoip at gmail.com
Thu Oct 2 00:56:43 EDT 2014


with  rx_samples_to_file without _4rx.rbf, Initially I tried on my i3, 4GB
ram, it gave me
some OOOO but was lesser than earlier, but I do not understand, my most of
the ram capacity and processor was sitting idle while it shows OOOO, why is
this strange behaviour
using uhd_rx_cfile getting similar result, but strangely, why it is low, at
4M sampling rate it was higher???


On Thu, Oct 2, 2014 at 9:27 AM, Marcus D. Leech <mleech at ripnet.com> wrote:

>  On 10/01/2014 11:46 PM, gsmandvoip wrote:
>
>  Yes I am running single channel, but when trying to achieve my desired
> sampling rate without _4rx.rbf, it says, requested sampling rate is not
> valid, adjusting to some 3.9M or so.
>  sorry for misleading info I gave earlier, I have i3, with 32 bit and i7
> with 64 bit, but getting same result on both machines
>
>  Here is my command to capture signal:
>
> ./rx_samples_to_file --args="fpga=usrp1_fpga_4rx.rbf, subdev=DBSRX"
> --freq "$FC" --rate="$SR" $FILE --nsamps "$NSAMPLES"
>
> and here is its output:
>
> Creating the usrp device with: fpga=usrp1_fpga_4rx.rbf, subdev=DBSRX...
> -- Loading firmware image: /usr/share/uhd/images/usrp1_fw.ihx... done
> -- Opening a USRP1 device...
> -- Loading FPGA image: /usr/share/uhd/images/usrp1_fpga_4rx.rbf... done
> -- Using FPGA clock rate of 52.000000MHz...
> *Error: LookupError: IndexError: multi_usrp::get_tx_subdev_spec(0) failed
> to make default spec - ValueError: The subdevice specification "A:0" is too
> long.*
> The user specified 1 channels, but there are only 0 tx dsps on mboard 0.
>
>
>  Don't use the _4rx image if you don't need it.
>
> The USRP1 only does strict-integer resampling, and with a master clock
> (NON STANDARD FOR USRP1) of 52.000MHz, 4Msps is not a sample rate
>   that it can produce.   Try 5.2Msps or 4.3333Msps.
>
> At 5.2Msps, it's recording at roughly 20.8Mbytes/second, so your system
> needs to be able to sustain that for at least as long as the capture lasts.
>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20141002/bbc274c7/attachment-0002.html>


More information about the USRP-users mailing list