[USRP-users] rx_samples_to_file issue

mleech at ripnet.com mleech at ripnet.com
Wed Oct 1 12:24:55 EDT 2014


 

That actually looks like a bug in rx_samples_to_file, in that it's
checking *TX* DSP configuration, which will fail in this case because 

 with the 4rx image, there is no TX-side DSP at all. 

On 2014-10-01 07:22, gsmandvoip via USRP-users wrote: 

> Hi list,
> when I am trying to run rx_samples_to_file, with following command:
> ./rx_samples_to_file --args="fpga=usrp1_fpga_4rx.rbf" --freq "945000000" --rate="8000000" $FILE --nsamps 
> getting following error:
> 
> UHD Warning:
> Unable to set the thread priority. Performance may be negatively affected.
> Please see the general application notes in the manual for instructions.
> EnvironmentError: OSError: error in pthread_setschedparam
> 
> Creating the usrp device with: fpga=usrp1_fpga_4rx.rbf...
> -- Loading firmware image: /usr/share/uhd/images/usrp1_fw.ihx... done
> -- Opening a USRP1 device...
> -- Loading FPGA image: /usr/share/uhd/images/usrp1_fpga_4rx.rbf... done
> -- Using FPGA clock rate of 52.000000MHz...
> Error: LookupError: IndexError: multi_usrp::get_tx_subdev_spec(0) failed to make default spec - ValueError: The subdevice specification "A:0" is too long.
> The user specified 1 channels, but there are only 0 tx dsps on mboard 0.
> 
> Can any body throw some light, what mistake I am doing.
> I am using ubuntu 14.04, 32 bit, gnuradio, 3.7, uhd driver latest installation
> 
> _______________________________________________
> USRP-users mailing list
> USRP-users at lists.ettus.com
> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com [1]
 

Links:
------
[1] http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20141001/0a6156d2/attachment-0002.html>


More information about the USRP-users mailing list