[USRP-users] N210: The total sum of rates exceeds the maximum capacity of the connection.

Anderson, Douglas J. danderson at its.bldrdoc.gov
Fri Dec 19 14:35:09 EST 2014


Hi all,

I'm trying to figure out if I may have missed something in setting up the connection between my USRP and laptop.

I'm getting the following error when I try and push the USRP's sample rate past 30MSps:

$ uhd_fft -s 50M -f 800M
linux; GNU C++ version 4.8.2; Boost_105400; UHD_003.008.001-42-g8c87a524
[...]
UHD Warning:
    The total sum of rates (50.000000 MSps on 1 channels) exceeds the maximum capacity of the connection.
    This can cause overflows (O).

Then the flowgraph hangs.

I'm using USRP N210 with SBX on Ubuntu laptop with 82577LM Gigabit Network card.

I have tried connected the USRP directly to the laptop and through a D-Link gigabit switch.

I ran the following commands as recommended on the Latency wiki page:

sudo modprobe -r e1000e
sudo modprobe e1000e InterruptThrottleRate=0 TxAbsIntDelay=0 TxIntDelay=0 RxAbsIntDelay=0 RxIntDelay=0

Here is the other relevant system info:

------------------------------------------------------
$ uname -r
3.17.0-031700-lowlatency

$ sudo lshw
[...]
        *-network
             description: Ethernet interface
             product: 82577LM Gigabit Network Connection
             vendor: Intel Corporation
             physical id: 19
             bus info: pci at 0000:00:19.0
             logical name: eth0
             version: 05
             serial: 00:26:b9:d2:92:0a
             size: 1Gbit/s
             capacity: 1Gbit/s
             width: 32 bits
             clock: 33MHz
             capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
             configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=2.3.2-k duplex=full firmware=0.12-1 ip=192.168.130.28 latency=0 link=yes multicast=yes port=twisted pair speed=1Gbit/s
             resources: irq:25 memory:f6900000-f691ffff memory:f6980000-f6980fff ioport:7040(size=32)
        *-usb:0
             description: USB controller
             product: 5 Series/3400 Series Chipset USB2 Enhanced Host Controller
             vendor: Intel Corporation
             physical id: 1a
             bus info: pci at 0000:00:1a.0
             version: 05
             width: 32 bits
             clock: 33MHz
             capabilities: pm debug ehci bus_master cap_list
             configuration: driver=ehci-pci latency=0
             resources: irq:16 memory:f6970000-f69703ff
[...]

$ modinfo e1000e |grep version:
version:        2.3.2-k

$ cat /etc/sysctl.conf |grep max
net.core.rmem_max=50000000
net.core.wmem_max=1048576

------------------------------------------------------

I guess I'm either missing something or not understanding something properly. Any help would be much appreciated!


-Doug


Douglas Anderson | Intern
DOC/NTIA/ITS-T | 325 Broadway St., Boulder, CO 80305 | P: 303 497 3582
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20141219/660f794e/attachment-0002.html>


More information about the USRP-users mailing list