[USRP-users] USRP2 + XCVR2450 configuration

Virag Varga virag.varga.it at gmail.com
Fri Dec 19 11:02:02 EST 2014


Hi Markus,

thank you for confirming that it's not normal! Until now it seemed
that the XCVR2450 fits properly (I got it this way), so I wanted a fix
in the software layer, but I've just disassembled/reassembled it, and
finally everything started to work.. Sorry for the PEBKAC though.

Bests,
Virag



On Fri, Dec 19, 2014 at 4:47 PM,  <mleech at ripnet.com> wrote:
> No, that isn't normal.
>
> Could you make certain that the XCVR2450 is properly seated?
>
>
>
>
>
> On 2014-12-19 10:43, Virag Varga via USRP-users wrote:
>
> Hi Ben,
>
> thanks for the advice, it really fixes the thread priority warning.
> But my main concern is still that the daughterboards don't seem to be
> recognized.. Or is it normal, not to have any information about their
> type in the uhd_usrp_probe output (see below)?
>
> Thanks again,
> Virag
>
>
> $ uhd_usrp_probe
> linux; GNU C++ version 4.8.2; Boost_105400; UHD_003.008.001-0-g2474ac32
>
> -- Opening a USRP2/N-Series device...
> -- Current recv frame size: 1472 bytes
> -- Current send frame size: 1472 bytes
>   _____________________________________________________
>  /
> |       Device: USRP2 / N-Series Device
> |     _____________________________________________________
> |    /
> |   |       Mboard: USRP2 r4
> |   |   hardware: 1024
> |   |   mac-addr: 00:50:c2:85:39:44
> |   |   ip-addr: 255.255.255.255
> |   |   subnet: 255.255.255.255
> |   |   gateway: 255.255.255.255
> |   |   gpsdo: none
> |   |   serial: 2372
> |   |   FW Version: 12.4
> |   |   FPGA Version: 10.1
> |   |
> |   |   Time sources: none, external, _external_, mimo
> |   |   Clock sources: internal, external, mimo
> |   |   Sensors: mimo_locked, ref_locked
> |   |     _____________________________________________________
> |   |    /
> |   |   |       RX DSP: 0
> |   |   |   Freq range: -50.000 to 50.000 MHz
> |   |     _____________________________________________________
> |   |    /
> |   |   |       RX DSP: 1
> |   |   |   Freq range: -50.000 to 50.000 MHz
> |   |     _____________________________________________________
> |   |    /
> |   |   |       RX Dboard: A
> |   |   |     _____________________________________________________
> |   |   |    /
> |   |   |   |       RX Frontend: 0
> |   |   |   |   Name: Unknown (0xffff) - 0
> |   |   |   |   Antennas:
> |   |   |   |   Sensors:
> |   |   |   |   Freq range: 0.000 to 0.000 MHz
> |   |   |   |   Gain Elements: None
> |   |   |   |   Connection Type: IQ
> |   |   |   |   Uses LO offset: No
> |   |   |     _____________________________________________________
> |   |   |    /
> |   |   |   |       RX Codec: A
> |   |   |   |   Name: ltc2284
> |   |   |   |   Gain Elements: None
> |   |     _____________________________________________________
> |   |    /
> |   |   |       TX DSP: 0
> |   |   |   Freq range: -50.000 to 50.000 MHz
> |   |     _____________________________________________________
> |   |    /
> |   |   |       TX Dboard: A
> |   |   |     _____________________________________________________
> |   |   |    /
> |   |   |   |       TX Frontend: 0
> |   |   |   |   Name: Unknown (0xffff) - 0
> |   |   |   |   Antennas:
> |   |   |   |   Sensors:
> |   |   |   |   Freq range: 0.000 to 0.000 MHz
> |   |   |   |   Gain Elements: None
> |   |   |   |   Connection Type: IQ
> |   |   |   |   Uses LO offset: No
> |   |   |     _____________________________________________________
> |   |   |    /
> |   |   |   |       TX Codec: A
> |   |   |   |   Name: ad9777
> |   |   |   |   Gain Elements: None
>
> On Thu, Dec 18, 2014 at 7:52 PM, Ben Hilburn <ben.hilburn at ettus.com> wrote:
>
> Virag - Please refer to the USRP manual:
> http://files.ettus.com/manual/page_general.html#general_threading It is not
> a critical error, but you may be able to improve performance. Cheers, Ben On
> Tue, Dec 16, 2014 at 3:15 AM, Virag Varga via USRP-users
> <usrp-users at lists.ettus.com> wrote:
>
> Hi, I'm quite new to the SDR world. I started with an USRP2 (r4) + XCVR2450
> dboard. I tried some examples with gnuradio, but I'm still not sure, if
> everything is setup correctly (mostly it seems I'm only getting noise).. For
> start, I don't think I should get this output (no sign that my daughterboard
> is recognized correctly) for uhd_usrp_probe (check down below). Do I miss
> some installation/configuration steps? Thanks for any help! Bests, Virag $
> uhd_usrp_probe linux; GNU C++ version 4.8.2; Boost_105400;
> UHD_003.008.000-release -- Opening a USRP2/N-Series device... -- Current
> recv frame size: 1472 bytes -- Current send frame size: 1472 bytes UHD
> Warning: Unable to set the thread priority. Performance may be negatively
> affected. Please see the general application notes in the manual for
> instructions. EnvironmentError: OSError: error in pthread_setschedparam
> _____________________________________________________ / | Device: USRP2 /
> N-Series Device | _____________________________________________________ | /
> | | Mboard: USRP2 r4 | | hardware: 1024 | | mac-addr: 00:50:c2:85:39:47 | |
> ip-addr: 255.255.255.255 | | subnet: 255.255.255.255 | | gateway:
> 255.255.255.255 | | gpsdo: none | | serial: 2375 | | FW Version: 12.4 | |
> FPGA Version: 10.0 | | | | Time sources: none, external, _external_, mimo |
> | Clock sources: internal, external, mimo | | Sensors: mimo_locked,
> ref_locked | | _____________________________________________________ | | / |
> | | RX DSP: 0 | | | Freq range: -50.000 to 50.000 MHz | |
> _____________________________________________________ | | / | | | RX DSP: 1
> | | | Freq range: -50.000 to 50.000 MHz | |
> _____________________________________________________ | | / | | | RX Dboard:
> A | | | _____________________________________________________ | | | / | | |
> | RX Frontend: 0 | | | | Name: Unknown (0xffff) - 0 | | | | Antennas: | | |
> | Sensors: | | | | Freq range: 0.000 to 0.000 MHz | | | | Gain Elements:
> None | | | | Connection Type: IQ | | | | Uses LO offset: No | | |
> _____________________________________________________ | | | / | | | | RX
> Codec: A | | | | Name: ltc2284 | | | | Gain Elements: None | |
> _____________________________________________________ | | / | | | TX DSP: 0
> | | | Freq range: -50.000 to 50.000 MHz | |
> _____________________________________________________ | | / | | | TX Dboard:
> A | | | _____________________________________________________ | | | / | | |
> | TX Frontend: 0 | | | | Name: Unknown (0xffff) - 0 | | | | Antennas: | | |
> | Sensors: | | | | Freq range: 0.000 to 0.000 MHz | | | | Gain Elements:
> None | | | | Connection Type: IQ | | | | Uses LO offset: No | | |
> _____________________________________________________ | | | / | | | | TX
> Codec: A | | | | Name: ad9777 | | | | Gain Elements: None
> _______________________________________________ USRP-users mailing list
> USRP-users at lists.ettus.com
> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
>
> _______________________________________________
> USRP-users mailing list
> USRP-users at lists.ettus.com
> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com




More information about the USRP-users mailing list