[USRP-users] [B200 USRP] HDSDR] " Failed to create USRP without device hint"

Balint Seeber balint.seeber at ettus.com
Fri Dec 19 00:47:54 EST 2014


Hi Rob,

The device changing after uhd_find_devices is a good sign. Please run
uhd_usrp_probe as well to ensure the FPGA is loaded correctly.

Zadig is always launched regardless of the state of your installation, so
if you've already installed the INFs for your USRP then you should be fine
and can close it.

The package with HDSDR/ExtIO_USRP actually already contains UHD, so it's
actually not necessary to install the official binary distribution from the
Ettus package. Of course you can do this too if you like, just be aware
about potential DLL loading conflicts. If you're not having success, and
you're able, use something like the Profile feature in Dependency Walker to
check which UHD.dll is being loaded-it should be the same one that is in
HDSDR's directory.

Kind regards,
Balint

On Monday, December 15, 2014, numeric via USRP-users <
usrp-users at lists.ettus.com> wrote:

> Hello group,
>
> I just received my USRP b200 circuit board:-) . I thought that I would
> start with known software for Windows 8.1 64 bit. I downloaded
> uhd_003.008.000-release_Win64_VS2013.exe from the ETTUS website and ran
> the installation. It installed to "Program files (x86)\UHD". When I tried
> to set the file path to "all users or current users" I get an error
> "Warning! PATH too long installer unable to modify PATH!". The [path
> >path.txt] from the command prompt, is 639 Hex characters long or 1593 in
> decimal. Excluding 0xd 0xa (EOL). Ignored the error. Next installed
> "ExtIO_USRP+FCD+BorIP_Setup.zip". It installed to "Program files
> (x86)\hdsdr". The program HDSDR was previously installed and used with the
> QS1R receiver using it's own EXTIO dll file. The QS1R extio dll was deleted
> before installing EXTIO_USRP to avoid potential conflicts. During the
> installation, zadaig.exe activated.
> Question:
> Since UHD.dll is already a driver do I need to use zadaig? The device
> manager indicated "Westbridge" when the USPR B200 is plugged in, it changes
> to B200 after running "uhd_find_devices.exe". I get the same device hint
> problem if zidaig is run or not.
> What files is EXTIO_USRP looking for?
>
> Question:
> What am I doing wrong?
>
> Any help is greatly appreciated,
> Rob
>
>
> _______________________________________________
> USRP-users mailing list
> USRP-users at lists.ettus.com
> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20141218/5577b074/attachment-0002.html>


More information about the USRP-users mailing list