[USRP-users] X310 register loopback fail

Emanuel.Staudinger at dlr.de Emanuel.Staudinger at dlr.de
Thu Dec 18 05:40:44 EST 2014


Hi there,

I recently got a X310 and get some weird IOErrors.
The X310 is connected via PCIe to my Win7 64bit workstation. I installed the latest 64bit UHD release (003.008.001).
The X310 is equipped with two CBX-120 boards and the internal GPSDO.

I tried uhd_find_devices.exe from UHD/bin and it worked fine, showing my X310 as resource RIO0.
Now I tried uhd_usrp_probe.exe: Sometimes this works fine, passing all tests and showing all details. But sometimes, it gives me an IOError during register loopback tests. Do you have any idea why? I also get this error sometimes, when I call usrp make within my C++ program.

Here is the dump from the console:
C:\Program Files (x86)\UHD\bin>uhd_usrp_probe.exe
Win32; Microsoft Visual C++ version 10.0; Boost_105400; UHD_003.008.001-release

-- X300 initialization sequence...
-- Connecting to niusrpriorpc at localhost:5444...
-- Using LVBITX bitfile C:\Program Files (x86)\UHD\share\uhd\images\usrp_x310_fpga_HGS.lvbitx...
-- Setup basic communication...
-- Loading values from EEPROM...
-- Setup RF frontend clocking...
-- Radio 1x clock:200
-- Detecting internal GPSDO.... Found an internal GPSDO
-- Initialize Radio control...
-- Performing register loopback test... Error: EnvironmentError: IOError: Radio ctrl (A) no response packet - AssertionError: bool
(buff)
  in unsigned __int64 __cdecl radio_ctrl_core_3000_impl::wait_for_ack(const bool)
  at ..\..\..\..\uhd\host\lib\usrp\cores\radio_ctrl_core_3000.cpp:192

Best regards,
Emanuel

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20141218/0a422697/attachment-0002.html>


More information about the USRP-users mailing list