[USRP-users] usrp b210 and mimo

Marcus D. Leech mleech at ripnet.com
Fri Dec 5 10:22:27 EST 2014


On 12/05/2014 08:50 AM, Juha Vierinen via USRP-users wrote:
> I've slowly gathered the courage to try out the B210 devices. I was 
> impressed by the fact that I could get 50 MHz of bandwidth out of it. 
> However, I immediately ran into problems with absolute timing.
>
> I've been using the B210 for mimo with USRP N200 devices for testing. 
> The N200 devices all nicely synchronize themselves to the external PPS 
> and after multiple restarts, their timing will be accurate. However, 
> the starting time of the B210 seems to have a random component with a 
> standard deviation of about 100 microseconds. Every time I restart 
> sampling, the offset between the N200 and the B210 is slightly 
> different. There is no change in the timing offset between the N200 
> devices.
>
> Is this a known issue, or am I doing something wrong?
>
> This is how I configure the devices:
>
> u.set_clock_source("external")
> u.set_time_source("external")
> tt = time.time()
> while tt-math.floor(tt) < 0.2 or tt-math.floor(tt) > 0.3:
>     tt = time.time()
>     time.sleep(0.01)
> print("Latching at "+str(tt))
> u.set_time_unknown_pps(uhd.time_spec(math.ceil(tt)+1.0))
> time.sleep(1)
> u.set_start_time(uhd.time_spec( starttime ) )
>
> juha
>
>
> _______________________________________________
> USRP-users mailing list
> USRP-users at lists.ettus.com
> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
Where and how does 'starttime' get set?

How are you distributing your 1PPS and 10Mhz clocks?


-- 
Marcus Leech
Principal Investigator
Shirleys Bay Radio Astronomy Consortium
http://www.sbrac.org

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20141205/9a0cf166/attachment-0002.html>


More information about the USRP-users mailing list