[USRP-users] B210 RF DC Offset Calibration Failure

Ian Buckley ianb at ionconcepts.com
Mon Dec 1 18:15:44 EST 2014


This is a vague answer since I've never worked on this aspect of AD9361 and someone may respond with a better response…..

My recollection is that despite the actually radio being spec'ed to 61.44MHz, experience demonstrated that some of the internal algorithms that perform calibrations start to have problems converging above 56MHz, which generally results in larger elapsed times before the device is ready to by used after configuration. Thus the origins of the warning message UHD gives for rates >56MHz. I don't recall hearing a good reason "why" this should be so from any ADI engineering folks.

So perhaps slow to converge manifests as failed to converge for some possible configurations? What happens if you back it off a little from the limit..say 61.0HMz?

-Ian


On Dec 1, 2014, at 1:58 PM, "Perelman, Nathan via USRP-users" <usrp-users at lists.ettus.com> wrote:

> I’m seeing this error attempting to use a B210 with a master clock rate of 61.44 MHz. This is with UHD 3.8.0. I’ve been just trying to test it out with the benchmark_rate application, but this is what happens:
>  
> $ ./benchmark_rate --rx_rate 61.44e6 --channels 0 --args "master_clock_rate=61.44e6" --rx_cpu=sc16
> linux; GNU C++ version 4.8.3 20140624 (Red Hat 4.8.3-1); Boost_105500; UHD_003.008.000-0-unknown
>  
>  
> Creating the usrp device with: master_clock_rate=61.44e6...
> -- Operating over USB 3.
> -- Detecting internal GPSDO.... Found an internal GPSDO
> -- Initialize CODEC control...
> -- Initialize Radio control...
> -- Performing register loopback test... pass
> -- Performing register loopback test... pass
> -- Performing CODEC loopback test... pass
> -- Performing CODEC loopback test... pass
> -- Asking for clock rate 61.440000 MHz
>  
> UHD Warning:
>     The requested clock rate 61.440000 MHz may cause slow configuration.
>     The driver recommends a master clock rate less than 56.000000 MHz.
> Error: RuntimeError: [ad9361_device_t] RF DC Offset Calibration Failure
>  
>  
> I get the same error for other rates I’ve tried in excess of 56 MHz. Any idea what causes this error and what I could do to resolve it? Thanks.
> -Nathan
> _______________________________________________
> USRP-users mailing list
> USRP-users at lists.ettus.com
> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20141201/5762041b/attachment-0002.html>


More information about the USRP-users mailing list