[USRP-users] Libertas driver for the W2CBW003

Philip Balister philip at opensdr.com
Wed Feb 27 14:28:28 EST 2013


On 02/27/2013 07:32 AM, Michael Yan wrote:
> Hi,
> 
> For our application, we wish to decode 802.11 packets on a consumer
> grade wifi module.  I'm reaching out to anyone who has replaced the
> Gumstix Overo board in the E100-series machine with a wifi-enabled
> Gumstix board, namely the Overo FireSTORM.  I have already replaced the
> board in our machine, but have been unable to get the wifi module to
> work (Everything else seems to work perfectly).

I've ordered a FireStorm so I can test this combination in an E100. I
can't get to this right away, but will try to get this sorted out so the
stock E100 (+ updates) support the wifi.

Philip

> 
> The FireSTORM has the exact same configuration as the packaged Gumstix
> board, but with the addition of a wifi module soldered on. I see no
> reason why reason it shouldn't work, and suspect it is a driver problem.
> 
> Namely, in my driver log, I found the following error:
> 
> lib80211: common routines for IEEE802.11 drivers
> lib80211_crypt: registered algorithm 'NULL'
> cfg80211: Calling CRDA to update world regulatory domain
> libertas_sdio: Libertas SDIO driver
> libertas_sdio: Copyright Pierre Ossman
> libertas_sdio: failed to find firmware (-2)
> libertas_sdio: probe of mmc1:0001:1 failed with error -2
> 
> Has anyone else attempted to do this?  I've tried downloading the
> relevant linux-firmware files and placing them in /lib/firmware, but
> that didn't seem to work (same error).
> 
> Regards,
> 
> Michael Yan
> HCLab, University of Waterloo
> 
> 
> _______________________________________________
> USRP-users mailing list
> USRP-users at lists.ettus.com
> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
> 
> 





More information about the USRP-users mailing list