[USRP-users] Libertas driver for the W2CBW003

Macre, William R wmacre at appcomsci.com
Wed Feb 27 11:33:46 EST 2013


Michael Yan:

The Overo FireSTORM uses the WI2Wi W2CBW003 - 802.11 b/g +Bluetooth part. using the  Marvell 88W8686 SDIO/GSPI chip.  The chip vendor recommends you use their WIFI driver and not the libertas_sdio driver supplied with the unit.  I would start with sales @ WI2WI:

David Brassfield
Wi2Wi, Inc.   WiFi/Bluetooth/GPS
Director of Sales,  Americas East
847-566-6630: Chicago Office
847-217-7360: Mobile
david at wi2wi.com

If you intend to modify the source code you will need to sign a Non-Disclosure Agreement (NDA) and a Source License Agreement (SLA) before they will provide you with the source code.

Wrm
      



-----Original Message-----
From: USRP-users [mailto:usrp-users-bounces at lists.ettus.com] On Behalf Of Michael Yan
Sent: Wednesday, February 27, 2013 10:32 AM
To: usrp-users at lists.ettus.com
Cc: mbaratvand at uwaterloo.ca
Subject: [USRP-users] Libertas driver for the W2CBW003

Hi,

For our application, we wish to decode 802.11 packets on a consumer grade wifi module.  I'm reaching out to anyone who has replaced the Gumstix Overo board in the E100-series machine with a wifi-enabled Gumstix board, namely the Overo FireSTORM.  I have already replaced the board in our machine, but have been unable to get the wifi module to work (Everything else seems to work perfectly).

The FireSTORM has the exact same configuration as the packaged Gumstix board, but with the addition of a wifi module soldered on. I see no reason why reason it shouldn't work, and suspect it is a driver problem.

Namely, in my driver log, I found the following error:

lib80211: common routines for IEEE802.11 drivers
lib80211_crypt: registered algorithm 'NULL'
cfg80211: Calling CRDA to update world regulatory domain
libertas_sdio: Libertas SDIO driver
libertas_sdio: Copyright Pierre Ossman
libertas_sdio: failed to find firmware (-2)
libertas_sdio: probe of mmc1:0001:1 failed with error -2

Has anyone else attempted to do this?  I've tried downloading the relevant linux-firmware files and placing them in /lib/firmware, but that didn't seem to work (same error).

Regards,

Michael Yan
HCLab, University of Waterloo


_______________________________________________
USRP-users mailing list
USRP-users at lists.ettus.com
http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com




More information about the USRP-users mailing list