[USRP-users] GCC internal compiler fault when installing GNU-Radio

Macre, William R wmacre at appcomsci.com
Thu Feb 7 12:14:57 EST 2013



The problem:

GCC internal compiler fault when installing GNU-Radio



What we need

    -the exact version of GCC;



gcc -v

Using built-in specs.

COLLECT_GCC=gcc

COLLECT_LTO_WRAPPER=/usr/libexec/gcc/arm-angstrom-linux-gnueabi/4.5.3/lto-wrapper

Target: arm-angstrom-linux-gnueabi

Configured with:

/home/oe-classic/oe/build/tmp-angstrom_2010_x/work/armv7a-angstrom-linux-gnueabi/gcc-4.5-r38.1+svnr170880/gcc-4_5-branch/configure

--build=x86_64-linux --host=arm-angstrom-linux-gnueabi

--target=arm-angstrom-linux-gnueabi --prefix=/usr --exec_prefix=/usr

--bindir=/usr/bin --sbindir=/usr/sbin --libexecdir=/usr/libexec

--datadir=/usr/share --sysconfdir=/etc --sharedstatedir=/com

--localstatedir=/var --libdir=/usr/lib --includedir=/usr/include

--oldincludedir=/usr/include --infodir=/usr/share/info --mandir=/usr/share/man

--with-libtool-sysroot=/home/oe-classic/oe/build/tmp-angstrom_2010_x/sysroots/armv7a-angstrom-linux-gnueabi

--enable-largefile --disable-nls --enable-ipv6 --with-gnu-ld --enable-shared

--enable-languages=c,c++,objc,fortran --enable-threads=posix --disable-multilib

--enable-c99 --enable-long-long --enable-symvers=gnu --enable-libstdcxx-pch

--program-prefix=arm-angstrom-linux-gnueabi- --enable-target-optspace

--enable-lto --enable-libssp --disable-bootstrap --disable-libgomp

--disable-libmudflap --with-float=softfp --with-local-prefix=/usr/local

--with-gxx-include-dir=/usr/include/c++/4.5.3

--with-build-sysroot=/home/oe-classic/oe/build/tmp-angstrom_2010_x/sysroots/armv7a-angstrom-linux-gnueabi

--enable-__cxa_atexit

Thread model: posix

gcc version 4.5.3 20110311 (prerelease) (GCC)



    -the system type;

USRP-E110: P/N UE-110-KIT







ERROR recevied while installing gnuradio.git

BUILD Script:  gnu_install.sh



./gnu_install.sh

#!/bin/sh

#              How do I install GNU Radio from source?



#   First, remove any existing installation by OpenEmbedded.

echo "First, remove any existing installation by OpenEmbedded."

opkg remove --force-depends gnuradio gnuradio-dev gnuradio-examples

task-gnuradio



# Note that building GNU Radio can take a significant amount of time!!

echo "Note that building GNU Radio can take a significant amount of time!!"

git clone http://gnuradio.org/git/gnuradio.git gnuradio.git

cd gnuradio.git

mkdir build

cd build

cmake -DCMAKE_INSTALL_PREFIX=/usr

-DCMAKE_TOOLCHAIN_FILE=../cmake/Toolchains/arm_cortex_a8_native.cmake

-DQT_QTCORE_INCLUDE_DIR=/usr/include/qt4/QtCore

-DQT_QTGUI_INCLUDE_DIR=/usr/include/qt4/QtGui

-DQT_QMAKE_EXECUTABLE=/usr/bin/qmake  -DENABLE_GR_QTGUI=ON

-DQT_LIBRARY_DIR=/usr/lib -DQT_INCLUDE_DIR=/usr/include/qt4/

-DQT_MOC_EXECUTABLE=/usr/bin/moc -DQT_UIC_EXECUTABLE=/usr/bin/uic

-DQT_RCC_EXECUTABLE=/usr/bin/rcc -DCMAKE_BUILD_TYPE=release  ../

make

make install

ldconfig





Console ERROR message:

[ 38%] Building CXX object

gnuradio-core/src/lib/swig/CMakeFiles/_gnuradio_core_general.dir/gnuradio_core_generalPYTHON_wrap.cxx.o

g++: Internal error: Killed (program cc1plus)

Please submit a full bug report.

See <http://gcc.gnu.org/bugs.html> for instructions.

make[2]: ***

[gnuradio-core/src/lib/swig/CMakeFiles/_gnuradio_core_general.dir/gnuradio_core_generalPYTHON_wrap.cxx.o]

Error 1

make[1]: ***

[gnuradio-core/src/lib/swig/CMakeFiles/_gnuradio_core_general.dir/all] Error 2
make: *** [all] Error 2

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20130207/7214cfd2/attachment-0002.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image001.gif
Type: image/gif
Size: 906 bytes
Desc: image001.gif
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20130207/7214cfd2/attachment.gif>


More information about the USRP-users mailing list