[USRP-users] Usrp e100 and gnuradio

Antonio Mancina amancina at mbigroup.it
Thu Sep 6 07:08:50 EDT 2012


Hi all,

I'm trying to port a software project of mine onto the E100 platform.
I'm getting rid of several libraries existing only in the x86 flavour,
like Intel TBB/MKL stuff.

Now I'm stuck because my software requires an header, usrp2/usrp2.h,
which starting from gnuradio 3.5.0 is not there anymore.

I tried to download the gnuradio 3.3.0 release, which is the one we
use on x86 platforms. I tried to build it through:

./configure && make

but the build fails at the following step

=================================================================
make[7]: Entering directory `/home/root/src/gnuradio-3.4.0/gruel/src/lib'

/bin/bash ../../../libtool --tag=CXX   --mode=link dist++ -g -O2  -Wall
-Woverloaded-virtual -pthread   -o test_gruel test_gruel.o
-lboost_thread -lboost_system -lboost_filesystem pmt/libpmt-qa.la
libgruel.la -lltdl
==================================================================

with the following error:

------------------------------------------------------------------
libtool: link: cannot find the library `=/usr/lib/libstdc++.la' or
unhandled argument `=/usr/lib/libstdc++.la'
------------------------------------------------------------------


The problem is that it seems to be trying to link against

=/usr/lib/libstdc++.la

with the '=' in front of it.

How to cope with this?

Thanks,
Antonio




More information about the USRP-users mailing list