[USRP-users] Unable compile UHD on OSX 10.8

Pol Henarejos pol.henarejos at cttc.es
Wed Sep 5 16:51:49 EDT 2012


Dear Michael,  

This is exactly what I did and I still get the same error. I do not know what I am doing wrong. It seems that could be multiple name spaces, used by old installations and getting into some kind of misunderstood.

The same problem also appears for Matlab users trying to compile mex files. But they solved the problem changing the SDKROOT variable to point to the correct one. Nevertheless I guess it is not my case.

Thanks for your time.  

--  

Pol Henarejos
Research Engineer, MSc
pol.henarejos at cttc.es (mailto:pol.henarejos at cttc.es)

Centre Tecnològic de Telecomunicacions de Catalunya (CTTC)
Engineering Unit
Parc Mediterrani de la Tecnologia
Av. Carl Friedrich Gauss, 7
08860 Castelldefels, Barcelona (Spain)
Tel: +34 93 396 71 70 Ext: 2177
Fax. +34 93 645 29 01
www.cttc.es (http://www.cttc.es)


Hi Pol - XCode as of 4.3 is a multi-stage process to get to work correctly, as described mostly in < https://trac.macports.org/wiki/ProblemHotlist >: 1) Download XCode from the Apple store; 2) Install XCode.app from the download; 3) Install the CLI tools (binaries, includes, libraries) from the correct preferences; 4) Select the version of XCode you wish to use, via "xcode-select ...". 5) Agree to the XCode license, via "xcodebuild -license". I tried a number of ports (in MacPorts) before doing the last 2 steps, and some worked while others didn't. I don't know why Apple is forcing us to do this nonsense, but here it is and that's what we have to do. So, my advice is to try some of the above and see if that helps. As I said, I've done all of these and both UHD and GR work for me. - MLD On Sep 5, 2012, at 3:38 PM, Pol Henarejos <pol.henarejos at cttc.es (http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com)> wrote: > What do you mean by "fully installed Xcode"? I downloaded it throughout Mac App Store and then Command Line Tools installed through Preference panel. > Xcode select points to /Applications/Xcode.app/Contents/Developer and I do not know what I could be missing.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20120905/2002274d/attachment-0002.html>


More information about the USRP-users mailing list