[USRP-users] Unable compile UHD on OSX 10.8

Michael Dickens mlk at alum.mit.edu
Wed Sep 5 15:47:52 EDT 2012


Hi Pol - XCode as of 4.3 is a multi-stage process to get to work correctly, as described mostly in < https://trac.macports.org/wiki/ProblemHotlist >:

1) Download XCode from the Apple store;

2) Install XCode.app from the download;

3) Install the CLI tools (binaries, includes, libraries) from the correct preferences;

4) Select the version of XCode you wish to use, via "xcode-select ...".

5) Agree to the XCode license, via "xcodebuild -license".

I tried a number of ports (in MacPorts) before doing the last 2 steps, and some worked while others didn't.  I don't know why Apple is forcing us to do this nonsense, but here it is and that's what we have to do.  So, my advice is to try some of the above and see if that helps.  As I said, I've done all of these and both UHD and GR work for me. - MLD

On Sep 5, 2012, at 3:38 PM, Pol Henarejos <pol.henarejos at cttc.es> wrote:
> What do you mean by "fully installed Xcode"? I downloaded it throughout Mac App Store and then Command Line Tools installed through Preference panel.
> Xcode select points to /Applications/Xcode.app/Contents/Developer and I do not know what I could be missing.




More information about the USRP-users mailing list