[USRP-users] tunnel.py doesn't receive packages when transmit and receive frequencies are different

Li Sun lisun.usrp at gmail.com
Fri Jun 29 17:58:15 EDT 2012


But can we set one daughter board's RX and TX at different frequency, e.g.
RX at 2.412GHz, TX at 2.432GHz ?

Li

On Fri, Jun 29, 2012 at 5:38 PM, Josh Blum <josh at ettus.com> wrote:

>
> > The wired thing is that when I set the frequencies of transmit and
> receive
> > different above 2.5GHz, packages can be again transmitted and received:
> > on machine A:
> > *sudo ./tunnel.py --tx-freq=2.51G --rx-freq=2.512G; sudo ifconfig gr0
> > 192.168.200.1 *
> > on machine B:
> > *sudo ./tunnel.py --tx-freq=2.512G --rx-freq=2.51G; sudo ifconfig gr0
> > 192.168.200.2*
> >
> > I am using USRP N210s and the daughter boards are both XCVR2450. Does
> > anyone can explain why the tunnel.py doesn't receive packages when
> transmit
> > and receive frequencies are different under 2.5GHz?
> >  --
>
>
> XCVR2450 has a shared LO for both RX and TX. You must make sure that the
> LO is the same frequency for the RX and TX setting. Otherwise, when you
> tune RX it will break the TX setting, and vice-versa.
>
> -josh
>
> _______________________________________________
> USRP-users mailing list
> USRP-users at lists.ettus.com
> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20120629/be08186a/attachment-0002.html>


More information about the USRP-users mailing list