[USRP-users] tunnel.py doesn't receive packages when transmit and receive frequencies are different

Weixian Zhou ideazwx at gmail.com
Fri Jun 29 17:30:24 EDT 2012


I run tunnel.py with two machines and there are some packages exchange
immediately after setting the network interface gr0. If I set the
frequencies of transmit and receive the same, packages are transmitted and
received at both machines:
on machine A:
*sudo ./tunnel.py -f 2.4xG ; sudo ifconfig gr0 192.168.200.1 *
on machine B:
*sudo ./tunnel.py -f 2.4xG ; sudo ifconfig gr0 192.168.200.2*

But when I set the frequencies of transmit and receive different under
2.5GHz, packages can't be received at both machines:
on machine A:
*sudo ./tunnel.py --tx-freq=2.4xG --rx-freq=2.4yG; sudo ifconfig gr0
192.168.200.1 *
on machine B:
*sudo ./tunnel.py --tx-freq=2.4yG --rx-freq=2.4xG; sudo ifconfig gr0
192.168.200.2*

The wired thing is that when I set the frequencies of transmit and receive
different above 2.5GHz, packages can be again transmitted and received:
on machine A:
*sudo ./tunnel.py --tx-freq=2.51G --rx-freq=2.512G; sudo ifconfig gr0
192.168.200.1 *
on machine B:
*sudo ./tunnel.py --tx-freq=2.512G --rx-freq=2.51G; sudo ifconfig gr0
192.168.200.2*

I am using USRP N210s and the daughter boards are both XCVR2450. Does
anyone can explain why the tunnel.py doesn't receive packages when transmit
and receive frequencies are different under 2.5GHz?
 --
Regards,
Weixian Zhou





-- 
Regards,
Weixian Zhou
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20120629/2a187f03/attachment-0002.html>


More information about the USRP-users mailing list