[USRP-users] E100 external reference and PPS

Nowlan, Sean Sean.Nowlan at gtri.gatech.edu
Tue Jun 19 16:27:04 EDT 2012


>> OK, good. The reason I ask is ours are modified to work at 6V and you'll fry a JL-sold device since it's expecting 5V.

Right, I had heard that. Glad I wasn't in danger of frying anything!

Unfortunately those fixes didn't help. I'm starting to suspect a firmware or FPGA image issue. What's also bizarre is that I don't hear a peep out of the TX/RX port when I run benchmark_tx.py. I don't even see a carrier tone. I don't think it's the RFX900 board I'm using since it has no problems when used with an N200.

I'm using the image e1xx-003 image with UHD 3.4.2 maint branch (built myself). Any ideas what could be happening?

Thanks,
Sean

On Tue, Jun 19, 2012 at 11:41 AM, Nowlan, Sean <Sean.Nowlan at gtri.gatech.edu<mailto:Sean.Nowlan at gtri.gatech.edu>> wrote:
Thanks! I'll definitely give that a shot.

I'm verifying ref_lock using get_mboard_sensor("ref_locked"), 0) and GPS lock by pin 3 on the Firefly (see page 4 of the Jackson Labs manual: http://www.jackson-labs.com/assets/uploads/main/firefly_1A_manual.pdf ). I'm using the GPSDO sold from Ettus.

Sean

From: Nick Foster [mailto:nick at ettus.com<mailto:nick at ettus.com>]
Sent: Tuesday, June 19, 2012 2:37 PM
To: Nowlan, Sean
Subject: Re: [USRP-users] E100 external reference and PPS

Attached is the relevant page of the E100 schematic for R3.

--n
On Tue, Jun 19, 2012 at 11:33 AM, Nick Foster <nick at ettus.com<mailto:nick at ettus.com>> wrote:
On Tue, Jun 19, 2012 at 11:26 AM, Nowlan, Sean <Sean.Nowlan at gtri.gatech.edu<mailto:Sean.Nowlan at gtri.gatech.edu>> wrote:
Hi,

It has been 3 weeks and nobody has responded to this question. Is there anything special I need to do to enable the external reference and PPS inputs on the E100 (rev. 3)? My only thoughts are that 1) there's something magic I have to do to get the E100 in the mood to use the external reference, or 2) the GPSDO unit I'm using is broken and the E100 can't lock to it.

For 10MHz ref, set J15 across pins 2&3, and use the set_clock_source("external", 0) command. How are you verifying lock?


Since the E100 (rev. 3) isn't configured to automatically detect the Jackson Labs GPSDO and read its RS-232 output, I used Pin 3 to confirm that the GPSDO is locked.

Did you obtain the Jackson Labs GPSDO from Ettus or from Jackson Labs?

--n


Any thoughts? Also, if Ettus has the rev. 3 schematic available somewhere, that would be very helpful. Thank you!

Best regards,
Sean Nowlan

From: usrp-users-bounces at lists.ettus.com<mailto:usrp-users-bounces at lists.ettus.com> [mailto:usrp-users-bounces at lists.ettus.com<mailto:usrp-users-bounces at lists.ettus.com>] On Behalf Of Nowlan, Sean
Sent: Friday, May 25, 2012 6:12 PM
To: USRP-users at lists.ettus.com<mailto:USRP-users at lists.ettus.com>
Subject: [USRP-users] E100 external reference and PPS

Hi all,

I have an E100 (rev 3) and I would like to use an external reference and PPS. I soldered straight SMA connectors onto J10 and J13 (REF IN and PPS IN, respectively). I'm supplying a 10MHz and PPS reference to the board, but I'm not sure how to tell the clock gen circuit to use the external reference.

I tried set_clock_source("external", 0) but the reference won't lock. Do I need to burn an EEPROM setting as with the N2xx? Is there a jumper I need to change?

FYI I installed UHD 3.4.2 release.

Thanks,
Sean

_______________________________________________
USRP-users mailing list
USRP-users at lists.ettus.com<mailto:USRP-users at lists.ettus.com>
http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20120619/e0cf6b0e/attachment-0002.html>


More information about the USRP-users mailing list