[USRP-users] does ubuntu 12.04 works for USRP N210?

Josh Blum josh at ettus.com
Mon Jun 11 11:52:35 EDT 2012


> 
> Hello there,
> 
> I'm facing similar issues with the uhd drivers UHD_OO3.004.002. 
> 
> I,ve downloaded and installed these drivers
> uhd_003.004.002-150-unstable_Ubuntu-11.10-x86_64.deb from
> http://files.ettus.com/binaries/uhd_unstable/latest/
> 

The debian package should be installed to /usr, but the error message is
from /usr/local I think you have multiple installs, one from source, one
from debian. Would that be a correct assumption?

> also,
> 
> I've loaded the following images to my USRP N200 box:
> 
> uhd-images_003.004.002-release.tar.gz  
> 
> from the same URL listed above and when I try to run ./tx_samples_from_file from
> ../uhd/host/build/examples, I get the following error
> 
> Error: RuntimeError: 
> Please update the firmware and FPGA images for your device.
> See the application notes for USRP2/N-Series for instructions.
> Expected FPGA compatibility number 10, but got 9:
> The FPGA build is not compatible with the host code build.
> Please run:
> "/usr/local/share/uhd/utils/usrp_n2xx_net_burner_gui.py" \
>     --fpga="/usr/local/share/uhd/images/usrp_n200_r2_fpga.bin" \
>     --fw="/usr/local/share/uhd/images/usrp_n200_fw.bin" \
>     --addr="192.168.10.3"
> 
> It seems like the latest uhd FPGA images available are lagging the current uhd
> driver version.
> 

Does the error go away when you run that command?

If not and this was a source build, see:
http://code.ettus.com/redmine/ettus/projects/uhd/wiki/UHD_Build#Firmware-and-FPGA-images

-josh




More information about the USRP-users mailing list