[USRP-users] Build-gnuradio Script Problem

Josh Blum josh at ettus.com
Sun Feb 26 16:08:28 EST 2012



On 02/26/2012 11:21 AM, Fatih Özçelik wrote:
> Hi,
> 
> I have just bought a USRP N-200 and I am trying to get it working. First,
> I've tried to install Uhd+gnu radio using build-gnuradio script. During the
> building step of uhd i got an error. I've tried the scirpt with -v again
> and the log message is as follows:
> 
> [ 1%] Built target doxygen_docs
> Scanning dependencies of target manual_html
> [  1%] Generating /home/fatih/Masaüstü/uhd/host/build/docs/index.html
> LookupError: unknown encoding: ASCII
> Exiting due to error.  Use "--traceback" to diagnose.
> Please report errors to <docutils-users at lists.sf.net>.
> Include "--traceback" output, Docutils version (0.6 [release]),
> Python version (2.6.6), your OS type & version, and the
> command line used.
> make[2]: *** [docs/index.html] Error 1
> make[1]: *** [docs/CMakeFiles/manual_html.dir/all] Error 2
> make: *** [all] Error 2
> 
> I also tried to build uhd manually but I got the same error messages.
> Please help.
> 

It appears that the rst2html is failing. I have never seen this error
before. For what its worth, here is my version info:
rst2html --version
rst2html (Docutils 0.7 [release], Python 2.7.2+, on linux2)

Fortunatly, building the manual is optional. You can disable the manual
with the following option:
cmake -DENABLE_MANUAL=OFF <src dir>

-Josh





More information about the USRP-users mailing list