[USRP-users] uhd_find_devices fails on E100

Ahmed Alsawi ahmedalsawi2012 at gmail.com
Fri Feb 24 17:18:52 EST 2012


aActually ,Nothing attached  other than console.
about re-seating the overo ,how to do it?
thanks
On Fri, Feb 24, 2012 at 8:56 PM, Ben Hilburn <ben.hilburn at ettus.com> wrote:

> Also, it's very possible that your Overo isn't seated properly.  Will you
> shut it down, pull off your Overo, and re-seat it?  Sometimes they get
> knocked around during shipping.
>
> Cheers,
> Ben
> ----------------------------
> Ben Hilburn <http://goo.gl/5DdZ3> @ Ettus Research, LLC<http://www.ettus.com/>
>
>
>
> On Fri, Feb 24, 2012 at 10:04 AM, Ben Hilburn <ben.hilburn at ettus.com>wrote:
>
>> Ahmed -
>>
>> It looks like your E100 cannot talk to its own EEPROM.  This is usually
>> caused by another device not behaving properly on the i2c bus.
>>
>> Do you have any peripherals plugged in to your E100? A monitor, for
>> example?
>>
>> If so, will you unplug all peripherals, reboot your E100, and try again?
>>
>> Cheers,
>> Ben
>> ----------------------------
>> Ben Hilburn <http://goo.gl/5DdZ3> @ Ettus Research, LLC<http://www.ettus.com/>
>>
>>
>>
>> On Fri, Feb 24, 2012 at 6:48 AM, Ahmed Alsawi <ahmedalsawi2012 at gmail.com>wrote:
>>
>>> hi all,
>>> I working on E100 with official image  UHD 003.004.
>>> After booting,When executing uhd_find_devices and uhd_usrp_probe they
>>> fail
>>> i think uhd_find_devices should have serial number.isn't it?
>>> Any idea what is wrong.
>>>
>>> root at usrp-e1xx:~# uhd_find_devices
>>> linux; GNU C++ version 4.5.3 20110311 (prerelease); Boost_104500;
>>> UHD_003.004.000-7dc76db
>>>
>>>  --------------------------------------------------
>>> -- UHD Device 0
>>> --------------------------------------------------
>>> Device Address:
>>>     type: e100
>>>     node: /dev/usrp_e0
>>>     name:
>>>     serial:
>>>
>>> root at usrp-e1xx:~# uhd_usrp_probe
>>> linux; GNU C++ version 4.5.3 20110311 (prerelease); Boost_104500;
>>> UHD_003.004.000-7dc76db
>>>
>>> -- Opening device node /dev/usrp_e0...
>>> Error: AssertionError: ::ioctl(_node_fd, I2C_RDWR, &data) >= 0
>>>   in virtual void i2c_dev_iface::write_i2c(uint8_t, const
>>> uhd::byte_vector_t&)
>>>   at /home/root/src/uhd.git/host/lib/usrp/e100/e100_ctrl.cpp:148
>>>
>>>
>>> _______________________________________________
>>> USRP-users mailing list
>>> USRP-users at lists.ettus.com
>>> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
>>>
>>>
>>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20120225/73aaf6ae/attachment-0002.html>


More information about the USRP-users mailing list