[USRP-users] problem installing uhd on ubuntu

Marcus D. Leech mleech at ripnet.com
Wed Feb 22 20:56:53 EST 2012


On 02/22/2012 08:23 PM, Stephen wrote:
> Hey,
>
> I'm having a problem trying to install UHD on ubuntu 10.10 x64. The
> first time I tried to install using the package I got an error saying
> libboost-dev was not installed. I installed that and tried again. Now  I
> get the error below. does anyone have any ideas?
> thanks,
>
I recommend that on Ubuntu and Fedora, you use the

http://www.sbrac.org/files/build-gnuradio

script.

It installs the latest UHD from source, as well as Gnu Radio.


> $ sudo dpkg -i UHD-003.003.002-Ubuntu-10.10-x86_64.deb
> (Reading database ... 457560 files and directories currently installed.)
> Preparing to replace uhd 003.003.002 (using
> UHD-003.003.002-Ubuntu-10.10-x86_64.deb) ...
> Unpacking replacement uhd ...
> Setting up uhd (003.003.002) ...
> dpkg (subprocess): unable to execute installed post-installation script
> (/var/lib/dpkg/info/uhd.postinst): Exec format error
> dpkg: error processing uhd (--install):
>   subprocess installed post-installation script returned error exit status 2
> Errors were encountered while processing:
>   uhd
>
> _______________________________________________
> USRP-users mailing list
> USRP-users at lists.ettus.com
> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
>
>


-- 
Marcus Leech
Principal Investigator
Shirleys Bay Radio Astronomy Consortium
http://www.sbrac.org






More information about the USRP-users mailing list