[USRP-users] problem with UHD driver 'no control response' and image burner for USRP2

Mike McLernon Mike.McLernon at mathworks.com
Wed Feb 15 09:29:47 EST 2012


Hi Sam,

Some thoughts:

1.       It seems like you are concerned about a fixed frame size of 358 samples.  In R2011b, you can use arbitrary frame sizes.

2.       Make sure you are using UHD 003.002.003, downloaded from http://files.ettus.com/uhd_releases/003_002_003/images-only/.

3.       The 16-bit complex data is sent as [16I16Q].

4.       Have you read through the "Getting Started with the SDRu" primer?  It's available when you type "help sdru" at the MATLAB command prompt, and click on the "Getting Started with SDRu" link.

5.       If you have additional MATLAB or Simulink questions, please contact our tech support staff, at support at mathworks.com<mailto:support at mathworks.com>.

Best,
Mike


From: usrp-users-bounces at lists.ettus.com [mailto:usrp-users-bounces at lists.ettus.com] On Behalf Of sam berhanu
Sent: Tuesday, February 14, 2012 6:32 PM
To: usrp-users at lists.ettus.com
Subject: [USRP-users] problem with UHD driver 'no control response' and image burner for USRP2

I am using the USRP2 hardware with simulink matlab version 2011b.

what prompted for me to look for the latest firmware was that I was getting an error. The setup is as rudimentary as it could be, a sine wave from a signal generator received on the BasicX A port, but I keep getting the error:
"could not execute UHD driver command in 'ReceiveData_C" RunTimeError. I am not really sure what that means. I am not doing anything exotic, just a simple receive on the radio of a sine wave at 45 MHz,  power of -7 dbm.

Another quesiton that is tied to the above though is:
I went on the ettus website (which most previous links are no more there, please please fix the help or knowledge base section) to find the latest firmwares for the USRP2 at http://code.ettus.com/redmine/ettus/projects/uhd/wiki#Binary-downloads.

the image burner GUI I found from http://code.ettus.com/redmine/ettus/projects/uhd/repository/revisions/master/changes/host/utils/usrp2_card_burner_gui.py
.

I installed first python, then tried to run the python burner. I tried to run the image burner for the gui but nothing seems to happen. I tried this on 4 different computers in the lab. What's bizarre is that I did this about two weeks ago. I would love for the instructions on how to burn the image onto the SD cards be found somewhere as the link is there no more at http://www.ettus.com/uhd_docs/manual/html/usrp2.html#load-the-images-onto-the-sd-card-usrp2-only<http://www.ettus.com/uhd_docs/manual/html/usrp2.>

I could definitely use specific information on how to get this thing going, i.e the error with the 'no control response'.

I also would like to know how to correctly use the image burner.

and another question I have,

the data that I saw from the receive USRP2 block in simulink  (2011a version with a different firmware than above and works relatively smoothly),- the frame size was set at 358 and couldn't be changed. the data type I was using for the block output was an int16 (signed). I felt as though there was no Q channel information even though both the I & Q paths were connected to QPSK modulated signal paths. it felt as if the channel concatanated the 16 wide I and 16 wide Q and sent on the firmware with 2011b but the 2011a version I was using completely ignored the Q channel.
Would be great if someone could inform how the data is exactly sent? ( i realize they are interleaved IQ but does that mean 8I8Q for int16 or does it mean [16I16Q] 358 samples?

sorry for rambling...i know i'm a noob but someone has to start somewhere

sam
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20120215/a0f6ffd6/attachment-0002.html>


More information about the USRP-users mailing list