[USRP-users] problem with UHD driver 'no control response' and image burner for USRP2

John Malsbury john.malsbury at ettus.com
Tue Feb 14 18:50:25 EST 2012


This is a link from the UHD manual, which we link to from our Resources 
page.  This link describes, among other things, how to use the card 
burner tool:

http://files.ettus.com/uhd_docs/manual/html/usrp2.html

This link, also found in the UHD manual, describes where you can find 
the images:

http://files.ettus.com/uhd_docs/manual/html/images.html

I will have to defer any Matlab specific questions to someone from 
Mathworks.

-John


On 2/14/2012 3:31 PM, sam berhanu wrote:
> I am using the USRP2 hardware with simulink matlab version 2011b.
>
> what prompted for me to look for the latest firmware was that I was 
> getting an error. The setup is as rudimentary as it could be, a sine 
> wave from a signal generator received on the BasicX A port, but I keep 
> getting the error:
> "could not execute UHD driver command in 'ReceiveData_C" RunTimeError. 
> I am not really sure what that means. I am not doing anything exotic, 
> just a simple receive on the radio of a sine wave at 45 MHz,  power of 
> -7 dbm.
>
> Another quesiton that is tied to the above though is:
> I went on the ettus website (which most previous links are no more 
> there, please please fix the help or knowledge base section) to find 
> the latest firmwares for the USRP2 at 
> http://code.ettus.com/redmine/ettus/projects/uhd/wiki#Binary-downloads.
>
> the image burner GUI I found from 
> http://code.ettus.com/redmine/ettus/projects/uhd/repository/revisions/master/changes/host/utils/usrp2_card_burner_gui.py 
>
> .
>
> I installed first python, then tried to run the python burner. I tried 
> to run the image burner for the gui but nothing seems to happen. I 
> tried this on 4 different computers in the lab. What's bizarre is that 
> I did this about two weeks ago. I would love for the instructions on 
> how to burn the image onto the SD cards be found somewhere as the link 
> is there no more 
> at/http://www.ettus.com/uhd_docs/manual/html/usrp2.html#load-the-images-onto-the-sd-card-usrp2-only 
> <http://www.ettus.com/uhd_docs/manual/html/usrp2.>/
>
> I could definitely use specific information on how to get this thing 
> going, i.e the error with the 'no control response'.
>
> I also would like to know how to correctly use the image burner.
>
> and another question I have,
>
> the data that I saw from the receive USRP2 block in simulink  (2011a 
> version with a different firmware than above and works relatively 
> smoothly),- the frame size was set at 358 and couldn't be changed. the 
> data type I was using for the block output was an int16 (signed). I 
> felt as though there was no Q channel information even though both the 
> I & Q paths were connected to QPSK modulated signal paths. it felt as 
> if the channel concatanated the 16 wide I and 16 wide Q and sent on 
> the firmware with 2011b but the 2011a version I was using completely 
> ignored the Q channel.
> Would be great if someone could inform how the data is exactly sent? ( 
> i realize they are interleaved IQ but does that mean 8I8Q for int16 or 
> does it mean [16I16Q] 358 samples?
>
> sorry for rambling...i know i'm a noob but someone has to start somewhere
>
> sam
>
>
> _______________________________________________
> USRP-users mailing list
> USRP-users at lists.ettus.com
> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20120214/0ce6d907/attachment-0002.html>


More information about the USRP-users mailing list