[USRP-users] FPGA image revision number

Josh Blum josh at ettus.com
Fri Feb 10 13:07:55 EST 2012



On 02/10/2012 10:01 AM, Lapointe, Benjamin - 1008 - MITLL wrote:
> Hi,
> 
> I am trying to burn new FPGA and FW images to my USRP N210.  I
> recently updated to a new version of UHD (003.004.000), and that
> caused me to get an error from usrp_n2xx_net_burner.py.  I know the
> N210 can have hardware revision r3 or r4, and my N210 is r3.  For my
> application, I have slightly modified the FPGA code.  Is there any
> way to specify which revision the FPGA code gets built with?  I am
> able to burn the stock fpga.bin and fw.bin files to my N210, but I
> get an error with my version of the fpga.bin file.
> 

You must build using the corresponding makefile for your device. In this
case Makefile.N210R3

> "./usrp_n2xx_net_burner.py", line 291, in burn_fw raise
> Exception("Error: incorrect FPGA image version. Please use the
> correct image for device %s" % n2xx_revs[hw_rev][0]) Exception:
> Error: incorrect FPGA image version. Please use the correct image for
> device n210_r3
> 

Its looking for specially that string as part of the filename. Try
renaming your custom build to be more like the stock file name.

-Josh

> _______________________________________________ USRP-users mailing
> list USRP-users at lists.ettus.com 
> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com




More information about the USRP-users mailing list