[USRP-users] OpenBTS and Loss of Monotonic error

Brad Lowe bhlowe at gmail.com
Wed Feb 8 19:49:31 EST 2012


Dear Group:

I purchased the Ettus B100 a few weeks ago and have been struggling
trying to get OpenBTS running. I've tried different versions of Linux,
I've tried different VM configurations, and in the latest attempt, I
built a platform exactly as described in the gnuradio wiki, however I
am still seeing Loss of Monotonic after about 3 seconds after I start
OpenBTS.

Problem Description
System can successfully find and probe the USB device.
System can successfully run uhd_fft.py and other gnuradio python utilities.
OpenBTS fails with "Loss of monotonic" and " assuming TRX is dead" messages:

Logs:
http://supersync.com/public/bts_out.txt  (OpenBTS Logs)
http://supersync.com/public/trx_out.txt  (TRX Log from Transciever52M,
with minor logging edits )
(or both as zip files: http://supersync.com/public/logs.zip )

Failing Point: (from TRX log)

1328747442.1556 DEEPDEBUG 3042274160 UHDDevice.cpp:630:readSamples:
Requested timestamp = 3.0024
1328747442.1556 ALARM 3042274160 UHDDevice.cpp:603:check_rx_md_err:
UHD: Loss of monotonic: 2.7652 delta=0.2373
1328747442.1557 ALARM 3042274160 UHDDevice.cpp:604:check_rx_md_err:
UHD: Current time: 2.7652
1328747442.1557 ALARM 3042274160 UHDDevice.cpp:605:check_rx_md_err:
UHD: Previous time: 3.0025

Hardware
HP DL320 G5, 2 x Dual Xeon Intel processors, 8Gb Ram
Ettus B100 (s/n E2R10Z7B1) w/  RX Dboard: WBX v3, (s/n EER1AW6XW)

Software
Fresh install, using Ubuntu 11.04
Built exactly as described  http://www.sbrac.org/files/build-gnuradio


Any guidance would be appreciated.  Or, if you have a link to a
reputable Live CD or VM image, that would be appreciated as well.
Thank you.

Best Regards,

-Brad




More information about the USRP-users mailing list