[USRP-users] E100 official image problem

Ahmed Alsawi ahmedalsawi2012 at gmail.com
Tue Feb 7 10:03:32 EST 2012


so why isn't booting???  i tried 2 card ,one of them is new ,,,.
I read on wiki that  unofficial image take 1.5 hour to boot ,,,does
official take
such time ?????

Please ,help

On Tue, Feb 7, 2012 at 4:51 PM, Philip Balister <philip at balister.org> wrote:

> On 02/06/2012 08:31 PM, Ahmed Alsawi wrote:
> > yes i made using the MakeSDCard.sh script using current image
> usrpe1xx-002 .
> >
> > - I am using the console only (no monitor)
> > - the output for my card
>
> So "modern" partition tools only care about sectors now. The
> cylinders/head business is leftover from the old days of rotating disk
> drives. Usually, the partition tools default to sector mode now and have
> a command to go back to CHS mode. So I think these warnings are harmless.
>
> The boot.scr is an optional file you can use to modify the u-boot
> behavior with a boot script. It is OK if there is not boot.scr file.
>
> Philip
>
> > -------- output ------------
> > Disk /dev/sdb: 8031 MB, 8031043584 bytes
> > 248 heads, 62 sectors/track, 1020 cylinders
> > Units = cylinders of 15376 * 512 = 7872512 bytes
> > Sector size (logical/physical): 512 bytes / 512 bytes
> > I/O size (minimum/optimal): 512 bytes / 512 bytes
> > Disk identifier: 0x00000000
> >
> >    Device Boot      Start         End      Blocks   Id  System
> > /dev/sdb1   *           1           9       65472    c  W95 FAT32 (LBA)
> > Partition 1 has different physical/logical beginnings (non-Linux?):
> >      phys=(0, 2, 3) logical=(0, 2, 5)
> > Partition 1 has different physical/logical endings:
> >      phys=(8, 40, 32) logical=(8, 130, 4)
> > Partition 1 does not end on cylinder boundary.
> > /dev/sdb2               9        1021     7777280   83  Linux
> > Partition 2 has different physical/logical beginnings (non-Linux?):
> >      phys=(8, 40, 33) logical=(8, 130, 5)
> > Partition 2 has different physical/logical endings:
> >      phys=(976, 98, 18) logical=(1020, 34, 4)
> > Partition 2 does not end on cylinder boundary.
> >
> >
> > On Tue, Feb 7, 2012 at 3:21 AM, Ben Hilburn <ben.hilburn at ettus.com>
> wrote:
> >
> >> Ahmed -
> >>
> >> Actually, no, you don't need to worry about that boot.scr error =)
> >>
> >> That said, there is obviously something wrong if the device doesn't
> boot!
> >>  You said you are using e1xx-002, which you made using the MakeSDCard.sh
> >> script, correct?
> >>
> >> A few things:
> >>
> >> 1) Is your E1xx connected to a monitor when you try to boot it?  If so,
> >> will you unplug the screen, and try again?
> >> 2) If the above doesn't work, will you put the SD card back into your
> PC,
> >> and give me the output of the following command?
> >>
> >> $ sudo fdisk -l
> >>
> >> Cheers,
> >> Ben
> >> ----------------------------
> >> Ben Hilburn <http://goo.gl/5DdZ3> @ Ettus Research, LLC<
> http://www.ettus.com/>
> >>
> >>
> >>
> >> On Mon, Feb 6, 2012 at 5:13 PM, Ahmed Alsawi <ahmedalsawi2012 at gmail.com
> >wrote:
> >>
> >>> sorry,I should have said problem with booting , I guess i need
> boot.scr.
> >>> Right?
> >>> Does anyone exactly to write in  hte boot.scr ??
> >>>
> >>> On Tue, Feb 7, 2012 at 2:22 AM, Ahmed Alsawi <
> ahmedalsawi2012 at gmail.com>wrote:
> >>>
> >>>> HI,
> >>>> i got the official image usrpe1xx_02 from wiki and used the script to
> >>>> make SD-card ,,,but when i powered the board
> >>>> it got stuck after Uncompressing Linux... done, booting the kernel.
> >>>> --------------- here the console output
> >>>> -----------------------------------------------
> >>>> No NAND detected
> >>>> OMAP3530-GP ES3.1
> >>>> Board revision: 1
> >>>> Reading boot sector
> >>>> Loading u-boot.bin from mmc
> >>>>
> >>>>
> >>>> U-Boot 2011.09-00000-gc714eec-dirty (Dec 03 2011 - 09:44:39)
> >>>>
> >>>> OMAP3530-GP ES3.1, CPU-OPP2, L3-165MHz, Max CPU Clock 720 mHz
> >>>> Gumstix Overo board + LPDDR/NAND
> >>>> I2C:   ready
> >>>> DRAM:  512 MiB
> >>>> NAND:  0 MiB
> >>>> MMC:   OMAP SD/MMC: 0
> >>>> *** Warning - readenv() failed, using default environment
> >>>>
> >>>> In:    serial
> >>>> Out:   serial
> >>>> Err:   serial
> >>>> Board revision: 1
> >>>> Direct connection on mmc2
> >>>> No EEPROM on expansion board
> >>>> Die ID #18340004000000000403730510011005
> >>>> Net:   smc911x-0
> >>>> Hit any key to stop autoboot:  0
> >>>> reading boot.scr
> >>>>
> >>>> ** Unable to read "boot.scr" from mmc 0:1 **
> >>>> reading uImage
> >>>>
> >>>> 2874540 bytes read
> >>>> Booting from mmc ...
> >>>> ## Booting kernel from Legacy Image at 82000000 ...
> >>>>    Image Name:   Angstrom/3.0-pm/usrp-e1xx
> >>>>    Image Type:   ARM Linux Kernel Image (uncompressed)
> >>>>    Data Size:    2874476 Bytes = 2.7 MiB
> >>>>    Load Address: 80008000
> >>>>    Entry Point:  80008000
> >>>>    Verifying Checksum ... OK
> >>>>    Loading Kernel Image ... OK
> >>>> OK
> >>>>
> >>>> Starting kernel ...
> >>>>
> >>>> Uncompressing Linux... done, booting the kernel.
> >>>>
> >>>
> >>>
> >>> _______________________________________________
> >>> USRP-users mailing list
> >>> USRP-users at lists.ettus.com
> >>> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
> >>>
> >>>
> >>
> >
> >
> >
> > _______________________________________________
> > USRP-users mailing list
> > USRP-users at lists.ettus.com
> > http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20120207/ff38fbdf/attachment-0002.html>


More information about the USRP-users mailing list