[USRP-users] usrp2 over switch

Juha Vierinen jvierine at gmail.com
Sun Nov 28 08:39:03 EST 2010


Just an update. I tried a different switch (D-Link) and the problem
seems to go away. Is it possible that the Dell switch drops the first
packet with a high probability?

juha

On Thu, Nov 25, 2010 at 09:20, Juha Vierinen <jvierine at gmail.com> wrote:
> Hi,
>
> Ethtool shows that the interfaces should be gigabit at least to the
> computer (I don't know how to see this with the switch).
>
> I tried 0.5 MHz, but the problem still persists with the switch. I
> also tried launching the two USRP2 devices separately and together,
> each time I had the same result. When I remove the switch, I don't
> have the problem. I think I will just use multiple network interfaces
> for now, but it would be nice (and more cost-effective) to be able to
> reliably use a switch.
>
> It could also be that I am not using the uhd interface correctly. The
> switch model might also be the source of the problem. I'm looking into
> these two possibilities now.
>
> juha
>
> On Tue, Nov 23, 2010 at 17:39, Josh Blum <josh at ettus.com> wrote:
>> Assuming there is now transmission (which you said (BTW this now works on
>> the flow control branch)), the switch is transparent to the system. That is,
>> USRP2 and UHD driver know nothing about it.
>>
>> Is it possible that one of the interfaces did not come up as gigabit speed
>> (between your switch and pc)? I wonder if you are seeing the result of a
>> bottle neck. Can you bring your receive rates down very low just to see that
>> you can receive from both devices?
>>
>> Are you using both USRP2s independently (two single usrps instantiations or
>> 1 multi usrp instantiation)?
>>
>> -Josh
>>
>> On 11/23/2010 01:47 AM, Juha Vierinen wrote:
>>>
>>> Hi,
>>>
>>> I have two usrp2 devices with the latest UHD firmware behind a Dell
>>> powerconnect 2708 switch. The devices are found nicely, but I have
>>> problems with streaming samples. Almost every other time I don't start
>>> receiving samples. The problem disappears when I remove the switch,
>>> then I always start receiving packets from the driver. I am always
>>> only receiving samples, which should work ok even behind a switch.
>>>
>>> Is this a problem of my switch?
>>>
>>> Does anyone know of a switch type/brand that works nicely with USRP2+UHD?
>>>
>>> juha
>>>
>>> _______________________________________________
>>> USRP-users mailing list
>>> USRP-users at lists.ettus.com
>>> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
>>
>> _______________________________________________
>> USRP-users mailing list
>> USRP-users at lists.ettus.com
>> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
>>
>




More information about the USRP-users mailing list