[USRP-users] USRP2(XCVR) in Simulink

Mikhail Tadjikov mtadjikov at ucla.edu
Mon Nov 22 18:27:33 EST 2010


Sorry about spamming. I've figured it out... it seems that lack of sleep was
the culprit causing all the issues. :-/

On Mon, Nov 22, 2010 at 6:32 AM, Mikhail Tadjikov <mtadjikov at ucla.edu>wrote:

> Hello Marc,
>
>  Is there a way to verify that the device is up and running w/ UDP fw?
> Something to the tune of find_usrps? I'm trying to isolate the problem right
> now, and I know it doesn't work in Matlab. But I'm not even sure if I can
> see the USRP2 or where along the chain it's broken.
>
> Thanks,
> Mikhail
>
> On Mon, Nov 22, 2010 at 6:03 AM, Marc Erickson <
> Marc.Erickson at mathworks.com> wrote:
>
>>  Hi Mikhail,
>>
>>
>>
>> The Simulink integration of the USRP **requires** a specific version of
>> the firmware and FPGA as outlined in the solution (
>> http://www.mathworks.com/support/solutions/en/data/1-CUN7JZ/index.html?product=CB&solution=1-CUN7JZ).
>> The UHD firmware is a completely different implementation that is not
>> compatible with the R2010b release.
>>
>>
>>
>> The solution gives specific links to compatible firmware and FPGA images.
>> For XCVR, you will need:
>>
>> firmware: http://ettus.com/u2bin/txrx_xcvr_udp_20100507.bin
>>
>> and
>>
>> fpga: http://code.ettus.com/redmine/ettus/attachments/74
>>
>>
>>
>> -- Marc
>>
>>
>>
>> *From:* usrp-users-bounces at lists.ettus.com [mailto:
>> usrp-users-bounces at lists.ettus.com] *On Behalf Of *Mikhail Tadjikov
>> *Sent:* Monday, November 22, 2010 8:53 AM
>> *To:* usrp-users at lists.ettus.com
>> *Subject:* [USRP-users] USRP2(XCVR) in Simulink
>>
>>
>>
>> Hello,
>>
>>
>>
>>  I've been hitting my head against the wall for quite a few hours now and
>> I just can't seem to make UHD work with Simulink (2010b). I've downloaded
>> all the latest FW & FPGA bits (from
>> http://www.ettus.com/downloads/uhd_images/), as well as, the latest uhd
>> from git. For some reason I consistently have 3 LED light up B,D,F. I've
>> checked and it seems that B is undocumented, so no clue as to what's
>> happening there (with raw fw just D & F light up).
>>
>> $ sudo ./uhd_find_devices
>>
>> linux; GNU C++ version 4.4.5; Boost_104200; UHD_20101117.172104.89ae5f3
>>
>>
>>
>> Warning:
>>
>>     Ignoring discovered device
>>
>>     Expected fpga compatibility number 2, but got 3767730177:
>>
>> [ Expected protocol compatibility number 6, but got 7: (with the
>> experimental FW from 10/22)]
>>
>>     The fpga build is not compatible with the host code build.
>>
>> No UHD Devices Found
>>
>>
>>
>> Also, I'm a little confused about all the differences between UDP and UHD
>> FW, since Mathworks suggests using the udp version of the FW, but no comment
>> on the matching FPGA bits (
>> http://www.mathworks.com/support/solutions/en/data/1-CUN7JZ/index.html?product=CB&solution=1-CUN7JZ
>> )
>>
>>
>>
>> I've also used Wireshark to monitor my traffic and USRP2 does seem to be
>> generating some traffic. Ping'ing also works.
>>
>>
>>
>> Any guidance on this would be greatly appreciated.
>>
>> Thank you.
>>
>>
>>
>>
>> --
>> Mikhail Tadjikov
>> Graduate Student
>> UCLA Class of 2010
>> Department of Electrical Engineering
>>
>> _______________________________________________
>> USRP-users mailing list
>> USRP-users at lists.ettus.com
>> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
>>
>>
>
>


-- 
Mikhail Tadjikov
Graduate Student
UCLA Class of 2010
Department of Electrical Engineering
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20101122/d4537c9b/attachment-0002.html>


More information about the USRP-users mailing list