[USRP-users] No UHD Devices Found (USRP1)

Josh Blum josh at joshknows.com
Thu Nov 11 17:16:19 EST 2010


> Still it complained:
>
> [foo at bar build]$ cmake -DCMAKE_INSTALL_PREFIX=/opt/uhd -DENABLE_USRP1=TRUE
> ../
> ...
> -- checking for module 'libusb-1.0'
> --   package 'libusb-1.0' not found
> -- Could NOT find LIBUSB  (missing:  LIBUSB_INCLUDE_DIR)
> -- Has USB support - not found
> -- Configuring interface address discovery...
> --   Interface address discovery supported through getifaddrs.
> -- Configuring USRP1 support...
> -- USRP1 support enabled by configure flag
> CMake Error at lib/usrp/usrp1/CMakeLists.txt:38 (MESSAGE):
>    USRP1 support enabled without USB support
> Call Stack (most recent call first):
>    lib/usrp/CMakeLists.txt:36 (INCLUDE)
>    lib/CMakeLists.txt:69 (INCLUDE)
>
>
> -- Configuring incomplete, errors occurred!
>
>
> Finally I tried:
>
> cmake -DCMAKE_INSTALL_PREFIX=/opt/uhd -DENABLE_USRP1=TRUE
> -DLIBUSB_INCLUDE_DIR=/usr/local/include/libusb-1.0/ ../
>


Is that were fedora install the libusb1.0 package, or did you build 
libusb1 from source?

> and this seemed to make cmake happy.
>
> Now I'm on to:
>
> /opt/uhd/bin/uhd_find_devices
> linux; GNU C++ version 4.4.4 20100630 (Red Hat 4.4.4-10); Boost_104100;
> UHD_20101109.230702.c0dfc2c
>
>
> Warning:
>      Could not locate USRP1 firmware.
>      Please install the images package.
>
> No UHD Devices Found
>
>

See

http://code.ettus.com/redmine/ettus/projects/uhd/wiki#Downloads

http://www.ettus.com/uhd_docs/manual/html/images.html

> After some head-scratching I followed the README in uhd/images, using:
> cmake -DCPACK_GENERATOR=RPM ../
> make package
> sudo rpm -i UHD-images-20101109.230702.c0dfc2c-Linux.rpm
>
> Finally, uhd_find_devices found my usrp1.
>
> Thanks for your help!
> -Steven
>
> (10 minutes of adding a few more notes to the install guide could save hours
> of answering questions from befuddled users like me in the months to come :)
>




More information about the USRP-users mailing list