[USRP-users] Configuration Simulink

Jorge Miguel jmiggal at gmail.com
Thu Nov 4 13:31:01 EDT 2010


Hi all,

I have the same problem.

When I receive/send information from/to the USRP2 I cannot manage to do it
in real time. It seems that Simulink is very heavy or that Windows doesn´t
give enough priority to Simulink process. It is also the reason why I loose
a lot of packets when I receive from the USRP.

I have a quite new quad core computer. Is there any special setting that
makes Simulink works in real time with the USRP2 ?

Regards,
Jorge,




> From: MOISES NAVARRO <moises.navarro at campus.uab.es>
>
> Dear All,
>
> I'm working with simulink and usrp2.
> I trying to synchronize with an OFDM signal.
> I noticed a possible problem.
>
> I set up the simulation for 10 seconds (stop time), but the simulation
> takes
> about 60 seconds. As I conclude that my processor can not generate the
> signal so fast, right?
>
> So I decided to create the signal and store it in a variable. Subsequently
> generated a program that only reads the variable and transmitted through
> the
> USRP.
>
> My surprise is that neither is able to run this program in real time (read
> and send a variable) it  takes around 15 seconds. I have configured the
> Decimation to 512 and SampleTime to 512/100e6.
>
> It is normal for a corel 2 duo is not capable of running at that speed? If
> I
> monitor the processor is at 100 %.....
>
> There any special settings for simulink work well? " Is there any way to
> configure simulink to work in real time with USRP2?
> and if the processor inst fast enough that appears a warning or error?
>
>
>
> Thank you very much
> Moses
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20101104/a723b26c/attachment-0002.html>


More information about the USRP-users mailing list